Bug 1312771 - Expose o-direct option in posix xlator via 'volume set' command
Expose o-direct option in posix xlator via 'volume set' command
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: posix (Show other bugs)
3.7.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
: Triaged
Depends On: 1312198
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 04:23 EST by Krutika Dhananjay
Modified: 2016-12-27 04:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1312198
Environment:
Last Closed: 2016-12-27 04:55:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2016-02-29 04:23:32 EST
+++ This bug was initially created as a clone of Bug #1312198 +++

Description of problem:
'gluster volume set <VOL> o-direct on' fails with the error 'this option does not exist'. We need to expose this option via the CLI.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-02-26 02:29:34 EST ---

REVIEW: http://review.gluster.org/13529 (mgmt/glusterd: Expose storage.o-direct via CLI) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-26 05:05:14 EST ---

REVIEW: http://review.gluster.org/13529 (glusterd,posix: Expose storage.o-direct via CLI) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-29 00:21:05 EST ---

REVIEW: http://review.gluster.org/13529 (glusterd,posix: Expose storage.o-direct via CLI) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 1 Vijay Bellur 2016-02-29 04:45:23 EST
REVIEW: http://review.gluster.org/13543 (glusterd,posix: Expose storage.o-direct via CLI) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Mike McCune 2016-03-28 18:51:39 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 3 Krutika Dhananjay 2016-12-27 04:55:05 EST
Closing this bug with WONTFIX as the reason since enabling o-direct just at posix layer can cause write failures with EINVAL due to offset and size alignment issues on O_DIRECT writes and therefore it is generally a bad practice.

Note You need to log in before you can comment on or make changes to this bug.