Bug 131280 - Current libidn has wrong ldconfig call in preun instead of postun
Current libidn has wrong ldconfig call in preun instead of postun
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libidn (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-30 13:43 EDT by Matthias Saou
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 0.5.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 17:03:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2004-08-30 13:43:54 EDT
Description of problem:
The current libidn package contains /sbin/ldconfig calls but the one
for uninstallation is run in preun when the libraries are still
present instead of during postun.

Version-Release number of selected component (if applicable):
libidn-0.5.4

How reproducible:
Always.

Steps to Reproduce:
1. rpm -q --scripts libidn-0.5.4

Actual results:
%preun
/sbin/ldconfig
(and other info related stuff which is fine)

Expected results:
%postun
/sbin/ldconfig

Additional info:
The install-info --delete call needs to stay in preun since it needs
to info file to still be present.
Comment 1 Joe Orton 2004-08-31 17:03:29 EDT
Thanks.

Note You need to log in before you can comment on or make changes to this bug.