Bug 1312816 - gfid-reset of a directory in distributed replicate volume doesn't set gfid on 2nd till last subvolumes
gfid-reset of a directory in distributed replicate volume doesn't set gfid on...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks: 1313693 1318427
  Show dependency treegraph
 
Reported: 2016-02-29 05:24 EST by Pranith Kumar K
Modified: 2016-06-16 09:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1313693 1318427 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:58:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2016-02-29 05:24:44 EST
Description of problem:
    Afr does dict_ref of the xattr_req that comes to it and deletes "gfid-req" key.
    Dht uses same dict to send lookup to other subvolumes. So in case of
    directories and more than 1 dht subvolumes, second subvolume till the last
    subvolume won't get a lookup request with "gfid-req". So gfid reset never
    happens on the directories in distributed replicate subvolume for 2nd till last
    subvolumes.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-02-29 05:26:17 EST
REVIEW: http://review.gluster.org/13545 (cluster/afr: Don't delete gfid-req from lookup request) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-03-01 03:58:38 EST
REVIEW: http://review.gluster.org/13545 (cluster/afr: Don't delete gfid-req from lookup request) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2016-03-01 21:36:25 EST
REVIEW: http://review.gluster.org/13545 (cluster/afr: Don't delete gfid-req from lookup request) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Vijay Bellur 2016-03-02 03:55:01 EST
COMMIT: http://review.gluster.org/13545 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 9b022c3a3f2f774904b5b458ae065425b46cc15d
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Sat Feb 27 23:08:06 2016 +0530

    cluster/afr: Don't delete gfid-req from lookup request
    
    Problem:
    Afr does dict_ref of the xattr_req that comes to it and deletes "gfid-req" key.
    Dht uses same dict to send lookup to other subvolumes. So in case of
    directories and more than 1 dht subvolumes, second subvolume till the last
    subvolume won't get a lookup request with "gfid-req". So gfid reset never
    happens on the directories in distributed replicate subvolume for 2nd till last
    subvolumes.
    
    Fix:
    Make a copy of lookup xattr request.
    
    Also fixed replies_wipe possibly resetting gfid to NULL gfid
    
    BUG: 1312816
    Change-Id: Ic16260e5a4664837d069c1dc05b9e96ca05bda88
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13545
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
Comment 5 Vijay Bellur 2016-03-16 12:28:37 EDT
REVIEW: http://review.gluster.org/13754 (cluster/afr: Enhance the test to be more robust) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 6 Vijay Bellur 2016-03-16 12:40:59 EDT
REVIEW: http://review.gluster.org/13754 (cluster/afr: Enhance the test to be more robust) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 7 Vijay Bellur 2016-03-17 02:21:52 EDT
REVIEW: http://review.gluster.org/13754 (cluster/afr: Enhance the test to be more robust) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 8 Vijay Bellur 2016-03-17 12:58:04 EDT
COMMIT: http://review.gluster.org/13754 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 857bad73b3313c895c736faa9a5ec71d046a3da7
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Mar 16 21:55:35 2016 +0530

    cluster/afr: Enhance the test to be more robust
    
    In some cases of dht, there is code path (dht_lookup_directory) where it sets
    gfid-req before lookup. This leads to successful setting of gfid when there are
    only two subvolumes in distribute. So increased number of replica subvolumes.
    Also increased number of directories.
    
    Change-Id: I17092ce6dc69c7fed6e6b380eb0fc0040f19c06a
    BUG: 1312816
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13754
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Tested-by: Ravishankar N <ravishankar@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 9 Niels de Vos 2016-06-16 09:58:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.