Bug 131283 - eog closes right after opening window to display attached image, as started by gnus
eog closes right after opening window to display attached image, as started b...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eog (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-30 13:49 EDT by Alexandre Oliva
Modified: 2013-03-05 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-11 12:56:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-08-30 13:49:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
As of the past few days, when I ask gnus to open an attachment of type
image/*, it starts eog and, instead of eog sticking around until I
tell it to quit, it quits immediately.  If I save the attachment in a
file and run eog by hand, or even if I start eog
$TMPDIR/emm.*/filename (that's where gnus saves attachments before it
starts a mime handler), it completes successfully.

Version-Release number of selected component (if applicable):
emacs-21.3-14 eog-2.7.1-1

How reproducible:
Always

Steps to Reproduce:
1.Open a message in gnus containing a MIME attachment of type image/*
2.Right click on the attachment header, and choose `View Externally'.

Actual Results:  The eog window pops up and goes away before you get a
chance to see the image.

Expected Results:  It should remain on screen, like it did before.

Additional info:
Comment 1 Bryan W Clark 2004-09-14 03:26:52 EDT
My gut says this is similar to bug 131113

Can you try to reproduce this in a similar way?
Comment 2 Alexandre Oliva 2004-09-14 09:08:42 EDT
I don't see why you think it's related.  Even the symptoms are
completely different.  When I start it from the command line, it works
fine.  It's only when gnus starts it that it fails, and  when it
fails, it doesn't leave a blank window, it quits immediately.
Comment 3 Jens Petersen 2004-09-29 11:19:58 EDT
Not sure what is going on, but our emacs package basically hasn't
changed since FC2.

This was working for you until recently?
Comment 4 Alexandre Oliva 2004-09-29 13:10:01 EDT
Yup, it worked until a few days before I reported the problem.  I
tried to duplicate the problem with other means, but failed.
Comment 5 Jens Petersen 2004-10-06 01:29:02 EDT
Hmmm, that suggests it may not be a problem with our emacs.
No other changes on your system?

There are no errors or warnings appearing in *Messages* or
some other temporary buffer by any chance?
Comment 6 Jens Petersen 2004-10-06 03:19:33 EDT
Hmmm, do you have gthumb installed?

Seems to work ok for me after some testing.
Comment 7 Jens Petersen 2004-10-06 03:26:12 EDT
I should add that the default viewer in /etc/mailcap for "image/*"
now appears to be gthumb: how are you configuring emacs to use eog?

[Personally I much prefer gthumb to eog anyway...]
Comment 8 Alexandre Oliva 2004-10-06 12:20:41 EDT
As for `No other changes', that's a resounding `NO' since my boxes
track rawhide.  gthumb indeed works, but back when I filed the bug
report, the default image/* handler was eog.  I don't have any
personal settings in this regard, and never had.

Since the problem is gone with default settings, but probably remains
if someone chooses eog as the default image/* handler, I'll reassign
to eog, such that the eog maintainer can give it a try and hopefully
verify the problem is gone, or fix it.  It's definitely lower priority
at this point.

Meanwhile, I'll try to figure out how to set up mailcap to use eog and
see how it goes.
Comment 9 Marco Pesenti Gritti 2004-11-08 14:09:51 EST
Removing from trackers since it's low priority now.
Comment 10 Alexandre Oliva 2005-03-11 12:56:54 EST
eog is gone, gthumb is working fine for the same purpose.

Note You need to log in before you can comment on or make changes to this bug.