Bug 1312831 - referencing absolute path of file is not supported
referencing absolute path of file is not supported
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openscap (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Martin Preisler
Marek Haicman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 05:48 EST by Marek Haicman
Modified: 2017-08-01 04:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1312824
Environment:
Last Closed: 2017-08-01 04:45:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Haicman 2016-02-29 05:48:29 EST
+++ This bug was initially created as a clone of Bug #1312824 +++

Description of problem:
I am not able to reference oval file via absolute path.

xccdf / check / check-content-ref / href is of type anyURI, which is defined in RFC 2396 ( https://www.ietf.org/rfc/rfc2396.txt ). Thus it should support file://<abs-path>

Version-Release number of selected component (if applicable):
openscap-1.2.5-3.el7

How reproducible:
reliably

Steps to Reproduce:
1. reference oval file with absolute path
2. oscap xccdf eval $xccdf

Actual results:
WARNING: Skipping /tmp/tmp.oBlqLIiXmD/file://tmp/tmp.oBlqLIiXmD/oval.xml file which is referenced from XCCDF content

Expected results:
/tmp/tmp.oBlqLIiXmD/oval.xml is used properly

Additional info:
Comment 2 Martin Preisler 2017-01-11 15:59:16 EST
Upstream fix proposed: https://github.com/OpenSCAP/openscap/pull/645
Comment 5 Marek Haicman 2017-05-12 10:07:39 EDT
Verified.

[0 root@qeos-145 unittests]# rpm -qa openscap
openscap-1.2.14-1.el7.x86_64


TEST: Load OVAL using absolute path
/tmp/tmp.sU3BguZDfN ~/rpmbuild/BUILD/openscap-1.2.14/tests/API/XCCDF/unittests
Stderr file = /tmp/test_xccdf_oval_absolute_path.err.gjJV2U
Result file = /tmp/test_xccdf_oval_absolute_path.out.result.3B81oh
Report file = /tmp/test_xccdf_oval_absolute_path.out.report.pq8862
Title
Rule  xccdf_moc.elpmaxe.www_rule_1
Result        pass

Title 
Rule  xccdf_moc.elpmaxe.www_rule_2
Result        pass

OVAL Results are exported correctly.
XCCDF Results are exported correctly.
~/rpmbuild/BUILD/openscap-1.2.14/tests/API/XCCDF/unittests
/tmp/tmp.Qmuvjc4pfL ~/rpmbuild/BUILD/openscap-1.2.14/tests/API/XCCDF/unittests
Stderr file = /tmp/test_xccdf_oval_absolute_path.err.75u4x1
Result file = /tmp/test_xccdf_oval_absolute_path.out.result.akfzZS
Report file = /tmp/test_xccdf_oval_absolute_path.out.report.5cIVT0
Title 
Rule  xccdf_moc.elpmaxe.www_rule_1
Result        pass

Title 
Rule  xccdf_moc.elpmaxe.www_rule_2
Result        pass

OVAL Results are exported correctly.
XCCDF Results are exported correctly.
~/rpmbuild/BUILD/openscap-1.2.14/tests/API/XCCDF/unittests
RESULT: PASSED
Comment 6 errata-xmlrpc 2017-08-01 04:45:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2291

Note You need to log in before you can comment on or make changes to this bug.