Bug 1312838 - [RFE] As a user I'd like to see my sync status from CLI
[RFE] As a user I'd like to see my sync status from CLI
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Tomas Strachota
jcallaha
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 06:02 EST by Tomas Strachota
Modified: 2016-07-27 07:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:30:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13616 None None None 2016-04-22 12:03 EDT

  None (edit)
Description Tomas Strachota 2016-02-29 06:02:46 EST
The command should display:

* time of last synchronization
* last sync errors
* environments that are out of sync
* progress and status of the current tasks
* content counts per environment and content view

Proposed command: 'hammer proxy content synchronization-status'

Since content counts can be longish and are probably more suitable to be displayed as a list, they could be handled by a separate command: 'hammer proxy content list'
Comment 1 Tomas Strachota 2016-02-29 06:02:48 EST
Created from redmine issue http://projects.theforeman.org/issues/13616
Comment 2 Tomas Strachota 2016-02-29 06:02:52 EST
Upstream bug assigned to tstrachota@redhat.com
Comment 4 Bryan Kearney 2016-03-02 18:10:32 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13616 has been closed
-------------
Anonymous
Applied in changeset commit:hammer-cli-katello|31062ae116efa8ab30ce3b01ea1d758fd417b790.
Comment 6 jcallaha 2016-04-11 16:32:43 EDT
Verified in Satellite 6.2 Beta Snap 6 Compose 1. Sync status now correctly displayed in hammer.
Comment 8 Bryan Kearney 2016-07-27 07:30:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.