This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1312839 - [RFE] As a user I'd like to cancel running synchronization from CLI
[RFE] As a user I'd like to cancel running synchronization from CLI
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: Tomas Strachota
Kedar Bidarkar
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 06:03 EST by Tomas Strachota
Modified: 2016-07-27 07:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:00:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13615 None None None 2016-04-22 12:41 EDT

  None (edit)
Description Tomas Strachota 2016-02-29 06:03:52 EST

    
Comment 1 Tomas Strachota 2016-02-29 06:03:54 EST
Created from redmine issue http://projects.theforeman.org/issues/13615
Comment 2 Tomas Strachota 2016-02-29 06:03:58 EST
Upstream bug assigned to tstrachota@redhat.com
Comment 3 Bryan Kearney 2016-03-02 18:00:39 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13615 has been closed
-------------
Anonymous
Applied in changeset commit:hammer-cli-katello|c1b8eb02f2d6df720d5f399d355e6d1b1fcc6c65.
Comment 7 Kedar Bidarkar 2016-05-24 11:13:43 EDT
[root@xyz ~]# hammer -u admin -p changeme capsule content info --id 2
Lifecycle Environments: 
 1) Name:          DEV
    Organization:  Default Organization
    Content Views: 
     1) Name:           RHEL 7 CV
        Composite:      no
        Last Published: 2016/05/24 12:11:22
        Content:        
            Hosts:          2
            Products:       2
            Yum repos:      3
            Docker repos:   0
            Packages:       15540
            Package groups: 143
            Errata:         1197
            Puppet modules: 0
     2) Name:           RHEL 6 CV
        Composite:      no
        Last Published: 2016/05/18 21:34:55
        Content:        
            Hosts:          2
            Products:       2
            Yum repos:      3
            Docker repos:   0
            Packages:       21902
            Package groups: 405
            Errata:         3639
            Puppet modules: 0
     3) Name:           Capsule RHEL 7 CV
        Composite:      no
        Last Published: 2016/05/19 14:40:36
        Content:        
            Hosts:          1
            Products:       3
            Yum repos:      3
            Docker repos:   0
            Packages:       11327
            Package groups: 73
            Errata:         1197
            Puppet modules: 0

[root@xyz ~]# hammer -u admin -p changeme capsule content synchronization-status  --id 2
Last sync:                    2016/05/24 12:40:14
Status:                       Capsule is synchronized
Currently running sync tasks: 

Last failure:                 
    Task id:  
    Messages:

[root@xyz ~]# hammer -u admin -p changeme capsule content synchronize --id 2 
[...........................................] [65%]



[root@xyz ~]# hammer -u admin -p changeme capsule content synchronization-status  --id 2
Last sync:                    2016/05/24 12:40:14
Status:                       Capsule is synchronized
Currently running sync tasks: 
 1) Task id:  1a2671db-a5bd-4fc9-8a75-fd5ae439cf4b
    Progress: 0%
Last failure:                 
    Task id:  
    Messages:

[root@xyz ~]# hammer -u admin -p changeme capsule content synchronization-status  --id 2
Last sync:                    2016/05/24 12:40:14
Status:                       Capsule is synchronized
Currently running sync tasks: 
 1) Task id:  1a2671db-a5bd-4fc9-8a75-fd5ae439cf4b
    Progress: 65%
Last failure:                 
    Task id:  
    Messages:

[root@xyz ~]# hammer -u admin -p changeme capsule content cancel-synchronization --id 2
Trying to cancel the synchronization...

[root@xyz ~]# hammer -u admin -p changeme capsule content synchronization-status  --id 2
Last sync:                    2016/05/24 12:40:14
Status:                       Capsule is synchronized
Currently running sync tasks: 

Last failure:                 
    Task id:  1a2671db-a5bd-4fc9-8a75-fd5ae439cf4b
    Messages: 
      Task canceled
      Task canceled
      Task canceled

[root@xyz ~]# hammer -u admin -p changeme capsule content synchronize --id 2 
[......................................................................] [100%]
Task canceled
Task canceled
Task canceled



VERIFIED with sat62-snap12.1
Comment 8 Bryan Kearney 2016-07-27 07:00:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.