Bug 1312840 - [RFE] As a user I'd like the capsule command to be alias of proxy
[RFE] As a user I'd like the capsule command to be alias of proxy
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Tomas Strachota
Stephen Benjamin
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 06:04 EST by Tomas Strachota
Modified: 2016-07-27 07:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:16:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13614 None None None 2016-04-22 13:00 EDT

  None (edit)
Description Tomas Strachota 2016-02-29 06:04:19 EST
Capsule and proxy should in fact be the same command.
Comment 1 Tomas Strachota 2016-02-29 06:04:21 EST
Created from redmine issue http://projects.theforeman.org/issues/13614
Comment 2 Tomas Strachota 2016-02-29 06:04:25 EST
Upstream bug assigned to tstrachota@redhat.com
Comment 3 Bryan Kearney 2016-02-29 12:06:22 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13614 has been closed
-------------
Anonymous
Applied in changeset commit:hammer-cli-katello|2ba9e4e9b45edbea7a2c359c230cd895a90ca44b.
Comment 6 Stephen Benjamin 2016-04-04 11:34:51 EDT
Verified.  The commands are the same.

[root@sat-r220-06 ~]# hammer capsule --help
Usage:
    hammer capsule [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
 SUBCOMMAND                    subcommand
 [ARG] ...                     subcommand arguments

Subcommands:
 content                       Manage the capsule content
 create                        Create a smart proxy
 delete                        Delete a smart proxy
 import-classes                Import puppet classes from puppet proxy.
 info                          Show a smart proxy
 list                          List all smart proxies
 refresh-features              Refresh smart proxy features
 update                        Update a smart proxy

Options:
 -h, --help                    print help




[root@sat-r220-06 ~]# hammer proxy --help
Usage:
    hammer proxy [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
 SUBCOMMAND                    subcommand
 [ARG] ...                     subcommand arguments

Subcommands:
 content                       Manage the capsule content
 create                        Create a smart proxy
 delete                        Delete a smart proxy
 import-classes                Import puppet classes from puppet proxy.
 info                          Show a smart proxy
 list                          List all smart proxies
 refresh-features              Refresh smart proxy features
 update                        Update a smart proxy

Options:
 -h, --help                    print help
Comment 8 Bryan Kearney 2016-07-27 07:16:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.