Bug 1312876 - Several failed tests on PowerPC boxes
Summary: Several failed tests on PowerPC boxes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: binutils
Version: 7.2
Hardware: powerpc
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Nick Clifton
QA Contact: Miloš Prchlík
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-29 12:31 UTC by Miloš Prchlík
Modified: 2016-11-04 01:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 01:55:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
gas.log (167.03 KB, text/plain)
2016-02-29 12:32 UTC, Miloš Prchlík
no flags Details
ld.log (1.84 MB, text/plain)
2016-02-29 12:34 UTC, Miloš Prchlík
no flags Details
Change PowerPC64 GAS testsuite to accomodate bad TLBIE instructions (740 bytes, patch)
2016-03-01 14:27 UTC, Nick Clifton
no flags Details | Diff
Fix PowerPC linker tests (5.55 KB, patch)
2016-03-01 15:22 UTC, Nick Clifton
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2265 normal SHIPPED_LIVE binutils bug fix update 2016-11-03 13:33:42 UTC

Comment 1 Miloš Prchlík 2016-02-29 12:32:42 UTC
Created attachment 1131521 [details]
gas.log

Comment 2 Miloš Prchlík 2016-02-29 12:34:12 UTC
Created attachment 1131522 [details]
ld.log

Comment 3 Nick Clifton 2016-03-01 14:25:54 UTC
Hi Miloš,

  The GAS failure is due to the patch that suppresses TLBIE instruction checking.  (I forgot to check that the GAS testsuite did not test the instruction, and of course it does).  I will upload a simple patch that will
fix that problem.

  The LD failures however are a mystery.  I cannot reproduce them.  I assume
therefore that they must be an artefact of running the tests natively.  I
could create a patch to just mark those tests as expected failures, but I
would prefer to get to the bottom of the problem.  (I suspect that I just need
to add a line to regexp files to skip dumps of the .data section).  Is there a
RHEL 7.3 PPC64 machine available that I can use for testing ?

Cheers
  Nick

Comment 4 Nick Clifton 2016-03-01 14:27:24 UTC
Created attachment 1131958 [details]
Change PowerPC64 GAS testsuite to accomodate bad TLBIE instructions

Comment 5 Nick Clifton 2016-03-01 15:22:19 UTC
Created attachment 1131983 [details]
Fix PowerPC linker tests

With access to a PP64 machine (thanks Milos), I was able to reproduce the 
failures and find the cause - the native ppc tools always create a .data section
even if one is not needed.  This patch tweaks the failing linker tests to allow
for this fact.

Once we have a QA ACK, the two patches should go in.

Comment 6 Nick Clifton 2016-03-01 16:18:43 UTC
Patches checked in.

Comment 8 Miloš Prchlík 2016-06-24 07:41:43 UTC
Verified for build binutils-2.25.1-19.base.el7.

Comment 10 errata-xmlrpc 2016-11-04 01:55:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2265.html


Note You need to log in before you can comment on or make changes to this bug.