Bug 1312879 - cannot refresh host devices of a host when device is assigned to multiple VMs
cannot refresh host devices of a host when device is assigned to multiple VMs
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
4.0.0
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.6.5
: 3.6.5
Assigned To: Martin Betak
Nisim Simsolo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 07:38 EST by Martin Polednik
Modified: 2016-04-21 10:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:38:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tjelinek: ovirt‑3.6.z?
rule-engine: planning_ack?
tjelinek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
server.log (476.86 KB, text/plain)
2016-02-29 07:38 EST, Martin Polednik
no flags Details
engine.log (11.77 MB, text/plain)
2016-02-29 07:45 EST, Martin Polednik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54612 master MERGED hostdev: Fix cleanup treatment in RefreshHostDevicesCommand 2016-03-15 10:14 EDT
oVirt gerrit 54766 ovirt-engine-3.6 MERGED hostdev: Fix cleanup treatment in RefreshHostDevicesCommand 2016-03-15 12:01 EDT

  None (edit)
Description Martin Polednik 2016-02-29 07:38:44 EST
Created attachment 1131523 [details]
server.log

Description of problem:
The refresh host capabilities button should refresh host devices. If a single host device (tested with USB) is assigned to multiple VMs, host device capabilities are not refreshed.


Version-Release number of selected component (if applicable):
ovirt-engine-4.0.0-0.0.master.20160222171138.git904ab61.fc23.noarch

How reproducible:
Always

Steps to Reproduce:
1. Assign a host device to >1 VM (USB mouse was used in this case),
2. remove the device from host,
3. refresh host capabilities.

Actual results:
The device list should be refreshed to reflect current host configuration.

Expected results:
The device list is *not* updated at all, including a device that was physically removed from the host.
Comment 1 Martin Polednik 2016-02-29 07:44:36 EST
Removing the devices from VMs seems to act as a workaround. Also found occurence of #1306333.
Comment 2 Martin Polednik 2016-02-29 07:45 EST
Created attachment 1131525 [details]
engine.log
Comment 3 Nisim Simsolo 2016-04-11 10:30:38 EDT
Verified on: 
rhevm-3.6.5-0.1.el6
qemu-kvm-rhev-2.3.0-31.el7_2.10.x86_64
libvirt-client-1.2.17-13.el7_2.4.x86_64
vdsm-4.17.25-0.el7ev.noarch
sanlock-3.2.4-2.el7_2.x86_64

Verification scenario: 
1. Plug USB device, refresh host capabilities and verify USB device is listed in host --> host devices sub tab.
2. Attach same USB device to 2 VMs.
3. Move host to maintenance (maintenance because hotplug/unplug is not supported yet).
4. unplug the device and activate host.
5. Verify USB device detached from both VMs and is not listed in the host --> host devices sub tab.

Note: in several cases, bug https://bugzilla.redhat.com/show_bug.cgi?id=1306333 can affect refresh host capabilities, and till this bug will be fixed, a restart of host libvirtd service can workaround this issue.

Note You need to log in before you can comment on or make changes to this bug.