Bug 1312890 - langpacks-en should be added
langpacks-en should be added
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: langpacks (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 08:06 EST by Mike FABIAN
Modified: 2016-02-29 10:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 10:16:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike FABIAN 2016-02-29 08:06:22 EST
Installing “langpacks-en_GB” with dnf will install glibc-langpacks-en:

    [mfabian@Fedora-Workstation-netinst-x86_6 ~]$ sudo dnf install langpacks-en_GB
    Last metadata expiration check performed 2:49:31 ago on Wed Feb 24 15:05:33 2016.
    Dependencies resolved.
    =====================================================================================
     Package                  Arch          Version                 Repository      Size
    =====================================================================================
    Installing:
     glibc-langpack-en        x86_64        2.23.90-2.fc25          rawhide        272 k
     langpacks-en_GB          noarch        1.0-6.fc25              rawhide        7.1 k
     
    Transaction Summary
    =====================================================================================
    Install  2 Packages
     
    Total download size: 279 k
    Installed size: 3.3 M
    Is this ok [y/N]:


That is good, but not everybody who wants glibc-langpack-en will
install langpacks-en_GB. A user of US English for example may
not install langpacks-en_GB and therefore not get the glibc-langpack-en he
needs.

Also, a libreoffice-langpacks-en exists:

[mfabian@Fedora-Workstation-netinst-x86_6 ~]$ sudo dnf search libreoffice-langpack-en
Last metadata expiration check performed 0:04:38 ago on Wed Feb 24 18:07:33 2016.
======================= N/S Matched: libreoffice-langpack-en ========================
libreoffice-langpack-en.x86_64 : English language pack for LibreOffice
[mfabian@Fedora-Workstation-netinst-x86_6 ~]$

This is also not automatically installed when installing langpacks-en_GB.

Therefore, I think a langpacks-en should be added.
Comment 1 Parag Nemade 2016-02-29 10:16:43 EST
Okay fixed this now in langpacks-1.0-7 build for f24+.
Comment 2 Carlos O'Donell 2016-02-29 10:21:25 EST
This is a Fedora 24 release blocker because it impacts Critical Path translations.

https://fedoraproject.org/wiki/Fedora_24_Final_Release_Criteria#Critical_path_translations

While the gettext-based translations should default to American English (likely the reason no langpack-en exists), such default translations do not include additional resources like American English localizations, which are required to complete the "translation" accurately e.g. What date format do you use? Withou langpack-en the user is limited to C, POSIX, or C.UTF-8 localization practices which do not match en_US.UTF-8 locale practices e.g. month name before day number.

There are two alternatives to solving this blocker:

(a) All installs must include en_US.utf8 in their minimal set of installs. This is not ideal because it is wasteful for non-English users.

(b) Create a langpack-en such that American English users, like all other users, can have this lanpack installed, and thus include glibc-langpack-en to provide the correct localizations.

This bug proposes (b).
Comment 3 Carlos O'Donell 2016-02-29 10:22:56 EST
Parag, Thanks for fixing so quickly!

Note You need to log in before you can comment on or make changes to this bug.