Bug 1312897 - glusterfs-server %post script is not quiet, prints "success" during installation
glusterfs-server %post script is not quiet, prints "success" during installation
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: packaging (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Reopened, Triaged
Depends On:
Blocks: 1315008
  Show dependency treegraph
 
Reported: 2016-02-29 08:27 EST by Richard W.M. Jones
Modified: 2016-06-16 09:58 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1315008 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:58:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2016-02-29 08:27:25 EST
Description of problem:

RPM scripts should normally be quiet (except if there's an error
of course), but the glusterfs-server one prints "success"
during RPM installation:


  Installing  : attr-2.4.47-16.fc24.x86_64                              102/152 
  Installing  : glusterfs-fuse-3.7.8-2.fc25.x86_64                      103/152 
  Installing  : glusterfs-server-3.7.8-2.fc25.x86_64                    104/152 
success
  Installing  : glusterfs-devel-3.7.8-2.fc25.x86_64                     105/152 
  Installing  : fuse-libs-2.9.4-4.fc24.x86_64                           106/152 


Version-Release number of selected component (if applicable):

glusterfs-server-3.7.8-2.fc25.x86_64

How reproducible:

100% probably

Steps to Reproduce:
1. Install Rawhide.
2. Install glusterfs-server.
Comment 1 Vijay Bellur 2016-03-03 14:51:46 EST
REVIEW: http://review.gluster.org/13596 (packaging: %post server isn't quiet) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Vijay Bellur 2016-03-04 19:47:17 EST
COMMIT: http://review.gluster.org/13596 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit fe382917793c00f4cbedeef175707d35cb208f5d
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Thu Mar 3 14:49:04 2016 -0500

    packaging: %post server isn't quiet
    
    firewall-cmd prints out "success" during install
    
    Change-Id: I9b0d3d38170d2fc41fefd6ef555a958c5eeb39aa
    BUG: 1312897
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13596
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Kaleb KEITHLEY 2016-03-05 10:43:16 EST
*** Bug 1315008 has been marked as a duplicate of this bug. ***
Comment 4 Niels de Vos 2016-06-16 09:58:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.