Bug 1312919 - gdb 7.11 has started pulling in gcc stack
gdb 7.11 has started pulling in gcc stack
Status: CLOSED DUPLICATE of bug 1306591
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 09:22 EST by Peter Robinson
Modified: 2016-02-29 10:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 09:30:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2016-02-29 09:22:36 EST
Generally we don't want to pull in the entire C toolchain for a standard debug tool. This is a regression and will needlessly bloat a standard user install.


$ dnf upgrade
Failed to set locale, defaulting to C
Last metadata expiration check performed 1:18:42 ago on Mon Feb 29 07:59:21 2016.
Dependencies resolved.
================================================================================
 Package         Arch      Version                   Repository Size
================================================================================
Installing:
 binutils        armv7hl   2.26-13.fc24              fedora     5.5 M
 cpp             armv7hl   6.0.0-0.13.fc24           fedora     7.1 M
 gcc             armv7hl   6.0.0-0.13.fc24           fedora      15 M
 gcc-gdb-plugin  armv7hl   6.0.0-0.13.fc24           fedora      61 k
 glibc-devel     armv7hl   2.23.1-4.fc24             fedora     931 k
 glibc-headers   armv7hl   2.23.1-4.fc24             fedora     481 k
 isl             armv7hl   0.14-5.fc24               fedora     382 k
 kernel-headers  armv7hl   4.5.0-0.rc5.git0.2.fc24   fedora     1.0 M
 libasan         armv7hl   6.0.0-0.13.fc24           fedora     294 k
 libatomic       armv7hl   6.0.0-0.13.fc24           fedora      20 k
 libmpc          armv7hl   1.0.2-5.fc24              fedora      47 k
 libubsan        armv7hl   6.0.0-0.13.fc24           fedora     110 k
Upgrading:
 gdb             armv7hl   7.11-58.fc24              fedora     2.7 M

Transaction Summary
================================================================================
Install  12 Packages
Upgrade   1 Package

Total download size: 34 M
Is this ok [y/N]:
Comment 1 Jan Kratochvil 2016-02-29 09:30:45 EST
This was already discussed in Bug 1306591 such as Bug 1306591 Comment 8.
Do you have any new information not contained there?

*** This bug has been marked as a duplicate of bug 1306591 ***
Comment 2 Peter Robinson 2016-02-29 10:04:55 EST
You'd be better off leaving this as a tracker bug, because it's a completely different component and hence impossible to find against the actual package that is causing the problem

Note You need to log in before you can comment on or make changes to this bug.