This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1312928 - SELinux is preventing fwupd from 'write' accesses on the directory 0000:00:02.0.
SELinux is preventing fwupd from 'write' accesses on the directory 0000:00:02.0.
Status: CLOSED DUPLICATE of bug 1300456
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b83942374b9094b38a81442d347...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 09:37 EST by Jared Smith
Modified: 2016-03-01 07:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 07:26:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jared Smith 2016-02-29 09:37:00 EST
Description of problem:
SELinux is preventing fwupd from 'write' accesses on the directory 0000:00:02.0.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that fwupd should be allowed write access on the 0000:00:02.0 directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep fwupd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:fwupd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:sysfs_t:s0
Target Objects                0000:00:02.0 [ dir ]
Source                        fwupd
Source Path                   fwupd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-175.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.5.0-0.rc5.git0.2.fc25.x86_64 #1
                              SMP Thu Feb 25 10:53:02 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-02-29 09:36:06 EST
Last Seen                     2016-02-29 09:36:06 EST
Local ID                      961ffd98-8631-4915-bfc8-baf3addd7e2b

Raw Audit Messages
type=AVC msg=audit(1456756566.732:397): avc:  denied  { write } for  pid=2673 comm="fwupd" name="0000:00:02.0" dev="sysfs" ino=4582 scontext=system_u:system_r:fwupd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sysfs_t:s0 tclass=dir permissive=1


Hash: fwupd,fwupd_t,sysfs_t,dir,write

Version-Release number of selected component:
selinux-policy-3.13.1-175.fc25.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc5.git0.2.fc25.x86_64
type:           libreport

Potential duplicate: bug 1300456
Comment 1 Lukas Vrabec 2016-03-01 07:26:06 EST

*** This bug has been marked as a duplicate of bug 1300456 ***

Note You need to log in before you can comment on or make changes to this bug.