Bug 131293 - kernel 533 kills ethernet
kernel 533 kills ethernet
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-30 15:06 EDT by Phil Schaffner
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:18:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Schaffner 2004-08-30 15:06:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
Updated FC3T1/rawhide system to kernel-2.6.8-1.533 and it broke 3Com
3c556B ehternet on IBM A21p ThinkPad notebook.  Continuous errors
logged to console starting during boot.  Boot completes and login is
possible, but network non-functional.  Works OK on 2.6.8-1.526 and
earlier, but requires noacpi to boot without similar problems.   See
bug # 
128711 and 126028.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.533

How reproducible:
Always

Steps to Reproduce:
1. Update to 533 kernel
2. Reboot
3.
    

Actual Results:  Ethernet errors.

Expected Results:  Continues to work.

Additional info:

[root@wx1 ~]# lspci
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host
bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge
(rev 03)
00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:03.0 Ethernet controller: 3Com Corporation 3c556B CardBus [Tornado]
(rev 20)
00:03.1 Communication controller: 3Com Corporation Mini PCI 56k
Winmodem (rev 20)
00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24
[CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility
M3 AGP 2x (rev 02)

Error messages:
eth0: transmit timed out, tx_status ff status ffff.
  diagnostics: net ffff media ffff dma ffffffff fifo ffff
eth0: Transmitter encountered 16 collisions -- network cable problem?
eth0: Interrupt posted but not delivered -- IRQ blocked by another device?
  Flags; bus-master 1, dirty 0(0) current 16(0)
  Transmit list ffffffff vs. 118b8200.
eth0: command 0x3002 did not complete! Status=0xffff
  0: @118b8200  length 8000002a status 0000002a
  1: @118b82a0  length 8000002a status 0000002a
  2: @118b8340  length 8000002a status 0000002a
  3: @118b83e0  length 80000062 status 00000062
  4: @118b8480  length 8000002a status 0000002a
  5: @118b8520  length 8000005b status 0c00005b
  6: @118b85c0  length 80000036 status 00000036
  7: @118b8660  length 80000036 status 00000036
  8: @118b8700  length 80000055 status 0c000055
  9: @118b87a0  length 80000055 status 0c000055
  10: @118b8840  length 80000068 status 0c000068
  11: @118b88e0  length 80000055 status 0c000055
  12: @118b8980  length 80000068 status 0c000068
  13: @118b8a20  length 80000078 status 0c000078
  14: @118b8ac0  length 8000004f status 8c00004f
  15: @118b8b60  length 8000004f status 8c00004f
Comment 1 Phil Schaffner 2004-09-08 12:53:08 EDT
Similar (bad) results for kernel versions 538, 540, 541.  Last kernel
to have working Ethernet on this hardware was 526, but that broke
after last yum update, even after downgrading module-init-tools. 
Tried FC3T2-candidate anaconda upgrade, then fresh install with no
improvement.
Comment 2 Phil Schaffner 2004-09-20 14:08:36 EDT
Not to state the obvious (still kernel-2.6.8-1.541) but the problem
persists for FC3T2.  Booted from installation CD #1 (linux acpi=off
askmethod) and attempted a network install.  Starts generating errors
as soon as network information is entered to the installer.

Comment 3 Phil Schaffner 2004-10-08 16:14:10 EDT
Wrote today's rawhide images/boot.iso to CD and attempted to boot A21p
for NFS network install.  Assuming that uses kernel-2.6.8-1.598  -
still has problems, although the symptoms have changed.  Booted with
"linux noacpi" (also tried acpi=off) Entered IP, netmask, gateway, DNS
info.  Long pause...

Finally get prompt for hostname/directory which finally fails saying
"That directory could not be mounted from the server."

On VC#4 one sees (allowing for typos):
...
<4>3c59x: Donald Becker and others.  www.scyld.com/network/vortex.html
<6>0000:00:03.0: 3Com PCI 3c556B Laptop Hurricane at 0x1800. Vers LK1.1.19
<7>PCI: Setting latency timer of device 0000:00:03.0 to 64
<3>*** EEPROM MAC address in invalid.
<3>3c59x: vortex_probe1 fails.  Returns -22
<4>3c59x: probe of 0000:00:03.0 failed with error -22
... stuff about ISO 9660 ...
<131>Oct  8 15:53:01 loader:  failed to set default route: Network is
unreachable

No repeating messages about "transmit timed out" as above.
Comment 4 Phil Schaffner 2004-10-12 09:05:47 EDT
Kernel 2.6.8-1.603 - problems persist.
Comment 5 Phil Schaffner 2004-11-15 09:14:03 EST
FC3 final - same problem.  Can't find any way to get NIC to work with
recent FC kernels on this laptop.
Comment 6 Phil Schaffner 2004-11-16 08:22:48 EST
Tried building "generic" 2.6.10-rc2 kernel - without ACPI support as
that has been problematic on ThinkPad A21p.  Works fine.  Problems
must be with FC patches or build options.  Let me know if info about
.config used would be helpful.
Comment 7 Dave Jones 2004-11-27 17:06:19 EST
how do things look with the current errata kernel ?
Comment 8 Phil Schaffner 2004-11-29 13:37:48 EST
Just rebooted 2.6.9-1.6_FC2 without acpi=off.  NIC did not work.  Relevant bit
from dmesg (very similar to previous reports):

PCI: Enabling device 0000:00:03.0 (0000 -> 0003)
ACPI: PCI interrupt 0000:00:03.0[A] -> GSI 11 (level, low) -> IRQ 11
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
0000:00:03.0: 3Com PCI 3c556B Laptop Hurricane at 0x1800. Vers LK1.1.19
PCI: Setting latency timer of device 0000:00:03.0 to 64
*** EEPROM MAC address is invalid.
3c59x: vortex_probe1 fails.  Returns -22
3c59x: probe of 0000:00:03.0 failed with error -22
ip_tables: (C) 2000-2002 Netfilter core team
ip_tables: (C) 2000-2002 Netfilter core team
ACPI: PCI interrupt 0000:00:03.0[A] -> GSI 11 (level, low) -> IRQ 11
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
0000:00:03.0: 3Com PCI 3c556B Laptop Hurricane at 0x1800. Vers LK1.1.19
*** EEPROM MAC address is invalid.
3c59x: vortex_probe1 fails.  Returns -22
3c59x: probe of 0000:00:03.0 failed with error -22
Comment 9 Phil Schaffner 2004-11-29 17:26:34 EST
Should have noted in Comment #8 that the NIC does work with acpi=off, as it has
for other FC2 kernels, but not for anything since FC3T1 in the FC3 series.  Also
took a gamble and installed kernel-2.6.9-1.681_FC3 (on FC2 system) which
required updating to modutils-2.4.26-16.  Same behavior as 2.6.9-1.6_FC2 (works
with acpi=off - which gives me some hope of updating to FC3 on this machine with
a yum upgrade).
Comment 10 Dave Jones 2005-07-15 15:09:36 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 11 Phil Schaffner 2005-07-15 18:18:02 EDT
Well, the behavior with acpi=off is different as far as the error output (much
less) but the NIC still fails to work.  Works with acpi=off, as have kernels
tried since kernel-2.6.9-1.681_FC3.  The system was previously upgraded to FC3
via yum as suggested above.

Tried the FC4 installer for a network install and that works as long as acpi=off
is used, unlike the FC3 installation kernel.  Changing status to
RESOLVED/CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.