Bug 1312949 - Remove old permissive SELinux domains in selinux-policy distgit repository
Remove old permissive SELinux domains in selinux-policy distgit repository
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 10:31 EST by Lukas Vrabec
Modified: 2016-11-03 22:43 EDT (History)
6 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-65.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 22:43:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Vrabec 2016-02-29 10:31:14 EST
Description of problem:
File permissivedomains.te contain old domains which run in permissive mode added in rhel7.2 devel phase. These domains should run in enforcing mode now. We need remove these domains. permissivedomains.te file should contain just permissive domains which will be added during rhel7.3 devel phase.

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-63.el7

How reproducible:
always

Steps to Reproduce:
1. rhpkg clone selinux-policy
2. cat permissivedomains.te

Actual results:
permissivedomains.te file contain types added in rhel7.2 devel phase. 

Expected results:
permissivedomains.te file doesn't contain types added in rhel7.2 devel phase.
Comment 1 Lukas Vrabec 2016-03-07 05:14:50 EST
commit f6b65dda6197348741edeb80f856772b96b7b599
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Mon Mar 7 11:10:19 2016 +0100

    Remove old permissive SELinux domains added in RHEL-7.2 devel phase.
    Resolves: rhbz#1312949
Comment 5 errata-xmlrpc 2016-11-03 22:43:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html

Note You need to log in before you can comment on or make changes to this bug.