Bug 1312951 - Live media creation broken by glibc langpack split
Live media creation broken by glibc langpack split
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
24
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F24AlphaBlocker
  Show dependency treegraph
 
Reported: 2016-02-29 10:34 EST by Adam Williamson
Modified: 2016-03-05 18:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-05 18:17:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2016-02-29 10:34:50 EST
Live image creation is currently failing for Rawhide and Fedora 24 due to the glibc langpack split. anaconda fails to start as the en langpack is missing, thus the image creation fails.

This is more or less the same problem as https://bugzilla.redhat.com/show_bug.cgi?id=1312607 , but I'm filing it separately since the planned 'fix' for that bug - adding the langpacks to the installer environment for the dedicated installer images - may not fix this case.

Having anaconda Requires: all langpacks would probably solve this case and all other anaconda-related cases, but may be too big of a hammer, that's still under discussion.

This is an automatic blocker: "Bugs which entirely prevent the composition of one or more of the release-blocking images required to be built for a currently-pending (pre-)release" (it prevents building Workstation and KDE lives for F24, both of which are release-blocking).
Comment 1 Adam Williamson 2016-03-05 18:17:17 EST
We've been getting lives for the last few days, so I think the glibc package changes resolved this.

Note You need to log in before you can comment on or make changes to this bug.