This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1312961 - Automate UI: The copy class screen hangs
Automate UI: The copy class screen hangs
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.6.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Dmitry Misharov
ui:automate
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 11:03 EST by mkanoor
Modified: 2016-07-15 09:24 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:39:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mkanoor 2016-02-29 11:03:52 EST
Description of problem:
The Copy Class in the Automate UI does the copy but the screen goes grey and you have to hit the back button to get out of it.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Copy a class using the Automate UI
2.
3.

Actual results:
After the copy the UI goes grey

Expected results:
After the copy the UI should be responsive

Additional info:
Comment 2 Harpreet Kataria 2016-03-08 11:16:35 EST
https://github.com/ManageIQ/manageiq/pull/7158
Comment 3 Harpreet Kataria 2016-03-08 15:49:52 EST
ignore comment #2
Comment 4 Harpreet Kataria 2016-03-15 10:47:52 EDT
https://github.com/ManageIQ/manageiq/pull/7300
Comment 5 CFME Bot 2016-03-16 13:46:14 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/397be35ba2d5e0cc4cd11febc0eeb009b7acdc4e

commit 397be35ba2d5e0cc4cd11febc0eeb009b7acdc4e
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Mar 15 10:42:08 2016 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Mar 15 17:45:51 2016 -0400

    No need to replace left side tree when loading copy objects form.
    
    Replacing of left side tree was causing tree to be replaced with a tree that's supposed to be displayed in Namespace popup on copy screen, causing screen to hang when reloading tree after save is pressed on copy objects form.
    fixed a typo introduced in cf2aa79adcae7449a079ecce4518ac085f0c9a6f that was causing it to display incorrect right cell title when copying objects in automate explorer.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1312961

 app/controllers/miq_ae_class_controller.rb       |  4 ++--
 spec/controllers/miq_ae_class_controller_spec.rb | 19 +++++++++++++++++++
 2 files changed, 21 insertions(+), 2 deletions(-)
Comment 7 Dmitry Misharov 2016-04-18 09:09:50 EDT
Verified fixed in 5.6.0.1-beta2.20160413141124_e25ac0e.
Comment 9 errata-xmlrpc 2016-06-29 11:39:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.