Bug 1313010 - Set max_resources_per_stack to -1 in /etc/heat/heat.conf
Set max_resources_per_stack to -1 in /etc/heat/heat.conf
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity unspecified
: Upstream M2
: 10.0 (Newton)
Assigned To: James Slagle
Alexander Chuzhoy
: TestOnly, Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 12:24 EST by James Slagle
Modified: 2017-01-23 16:01 EST (History)
6 users (show)

See Also:
Fixed In Version: instack-undercloud-2.2.5-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-23 16:01:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 286165 None None None 2016-02-29 12:25 EST
OpenStack gerrit 286746 None None None 2016-03-01 12:59 EST

  None (edit)
Description James Slagle 2016-02-29 12:24:45 EST
Set max_resources_per_stack to -1
    
    The max_resources_per_stack configuration option for Heat engine is
    meant to prevent DOS attacks by large stacks. For TripleO, the check
    itself is actually quite resource instensive since it takes a while to
    actually count the resources in all the nested stacks.
    
    The tenant in the undercloud is trusted anyway.
    
    Setting the option to -1 disables the check and makes a significant
    improvement in overcloud deployment time.
Comment 2 Alexander Chuzhoy 2016-03-11 19:26:21 EST
FailedQA

Environment:instack-undercloud-2.2.5-1.el7ost.noarch


grep max_resources_per_stack /etc/heat/heat.conf
#max_resources_per_stack = 1000
Comment 4 Mike Burns 2016-04-07 17:11:06 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Alexander Chuzhoy 2016-12-06 10:07:43 EST
Verified:

Environment:
instack-undercloud-5.1.0-4.el7ost.noarch

[stack@undercloud-0 ~]$ sudo grep max_resources_per_stack /etc/heat/heat.conf
#max_resources_per_stack = 1000
max_resources_per_stack = -1
Comment 8 Lon Hohberger 2017-01-23 16:01:48 EST
According to our records, this should be resolved by instack-undercloud-5.1.0-4.el7ost.  This build is available now.

Note You need to log in before you can comment on or make changes to this bug.