Bug 1313018 - Segfault on startup
Segfault on startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mongodb (Show other bugs)
24
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Skalický
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1315905
  Show dependency treegraph
 
Reported: 2016-02-29 13:03 EST by Remi Collet
Modified: 2016-04-06 10:07 EDT (History)
9 users (show)

See Also:
Fixed In Version: mongodb-3.2.3-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 10:07:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2016-02-29 13:03:20 EST
See: https://kojipkgs.fedoraproject.org//work/tasks/7897/13177897/build.log

+ mkdir dbtest
+ mongod --journal --logpath /builddir/build/BUILD/mongo-c-driver-1.3.3/server.log --pidfilepath /builddir/build/BUILD/mongo-c-driver-1.3.3/server.pid --dbpath /builddir/build/BUILD/mongo-c-driver-1.3.3/dbtest --fork
/var/tmp/rpm-tmp.cx1CE0: line 38: 12847 Segmentation fault      (core dumped) mongod --journal --logpath $PWD/server.log --pidfilepath $PWD/server.pid --dbpath $PWD/dbtest --fork
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.cx1CE0 (%check)


Don't know if this is related to FTBFS #1305214, or if some locale is missing (splitted glibc)
Comment 1 Petr Pisar 2016-03-01 02:59:43 EST
This happens on i686 only. I cannot reproduce on x86_64 even after uninstalling glibc-langpack-en. First perl-MongoDB failed build because of this has these build root changes:

        perl-Module-Install 	1.16-7.fc24 	> 	1.16-8.fc24
	perl-Module-CoreList 	1:5.20160120-2.fc24 	> 	1:5.20160121-1.fc24
	krb5-libs 	1.14-22.fc24 	> 	1.14-23.fc24
	python3-pip 	7.1.0-4.fc24 	> 	8.0.2-1.fc24
	setup 	2.9.8-3.fc24 	> 	2.10.1-1.fc24
	device-mapper-libs 	1.02.116-1.fc24 	> 	1.02.117-1.fc24
	device-mapper 	1.02.116-1.fc24 	> 	1.02.117-1.fc24
	audit-libs 	2.5-2.fc24 	> 	2.5-3.fc24
Comment 2 Remi Collet 2016-03-01 04:34:42 EST
@Petr: right, thanks.
Comment 3 Petr Pisar 2016-03-09 04:59:31 EST
I managed to build perl-MongoDB in F25 now. The same perl-MongoDB and mongodb still fail in F24. This is a difference (ignoring release numbers) between the F24 and F25 build roots:

Removed packages:
        device-mapper-1.02.117
        device-mapper-libs-1.02.117
        fedora-release-24
        fedora-repos-24
        glibc-2.23.1
        glibc-all-langpacks-2.23.1
        glibc-common-2.23.1
        glibc-devel-2.23.1
        glibc-headers-2.23.1
        gperftools-libs-2.4.90
        libnghttp2-1.7.1
        librepo-1.7.17
        perl-Mojolicious-6.46
        perl-Moo-2.000002
        python3-librepo-1.7.17
        setup-2.10.1
Added packages:
        device-mapper-1.02.119
        device-mapper-libs-1.02.119
        fedora-release-25
        fedora-repos-25
        fedora-repos-rawhide-25
        glibc-2.23.90
        glibc-all-langpacks-2.23.90
        glibc-common-2.23.90
        glibc-devel-2.23.90
        glibc-headers-2.23.90
        gperftools-libs-2.4.91
        libnghttp2-1.8.0
        librepo-1.7.18
        perl-Mojolicious-6.53
        perl-Moo-2.001001
        python3-librepo-1.7.18
        setup-2.10.2

These packages changed both when failure emerged and when failure disappeared:

Package               Good till        First bad        Last bad         Good again
setup                 2.9.8-3.fc24     2.10.1-1.fc24    2.10.1-1.fc24    2.10.2-1.fc25    
device-mapper         1.02.116-1.fc24  1.02.117-1.fc24  1.02.117-4.fc24  1.02.119-1.fc25
(device-mapper-libs)
Comment 4 Marek Skalický 2016-03-09 05:24:12 EST
This is caused by gperftools - builds are done, no Bodhi update for F24 yet.

bug 1312462
Comment 5 Fedora Update System 2016-04-01 03:07:48 EDT
mongodb-3.2.3-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-150e04ec3b
Comment 6 Marek Skalický 2016-04-01 03:12:11 EDT
This bug is fixed in above mentioned update. So please test it...

For Fedora rawhide (F25) builds are not done yet. It is because new version of gcc with fix is failing to build.
Comment 7 Fedora Update System 2016-04-02 01:25:03 EDT
mongodb-3.2.3-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-150e04ec3b
Comment 8 Fedora Update System 2016-04-06 10:07:28 EDT
mongodb-3.2.3-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.