This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1313021 - banshee can't find /usr/lib/libMonoPosixHelper.so
banshee can't find /usr/lib/libMonoPosixHelper.so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Timotheus Pokorra
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 13:19 EST by Valdis Kletnieks
Modified: 2016-03-01 04:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 04:10:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2016-02-29 13:19:35 EST
Description of problem:
After upgrading to mono-core 4.3.2-4.fc25.x86_64, the banshee application fails to start, apparently due to a 32/64 bit file path confusion.

% banshee
[Info  12:54:15.437] Running Banshee 2.6.2: [Fedora24-2.6.2-15.fc24 (linux-gnu, x86_64) @ 2016-02-12 19:15:38 UTC]
Exception has been thrown by the target of an invocation.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeInitializationException: The type initializer for 'Mono.Unix.Native.Stdlib' threw an exception. ---> System.DllNotFoundException: /usr/lib/libMonoPosixHelper.so

This is a 64-bit box, and the library *is* there:

ls -l ls -l /usr/lib64/libMonoPosixHelper.so
-rwxr-xr-x. 1 root root 256296 Feb 27 03:39 /usr/lib64/libMonoPosixHelper.so

Reverting back to the 4.2.2-3.fc24.x86_64 version makes things work again.


Version-Release number of selected component (if applicable):
mono-core 4.3.2-4.fc25.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Timotheus Pokorra 2016-02-29 14:35:16 EST
Thanks for reporting this!

The problem is in /etc/mono/config

The line <dllmap dll="MonoPosixHelper" target="$mono_libdir/libMonoPosixHelper.so" os="!windows" />
needs to be changed to
target="libMonoPosixHelper.so", I think.

I will try if that solves the issue, and then fix it in Rawhide tomorrow.
Comment 2 Valdis Kletnieks 2016-02-29 17:35:02 EST
Confirming that removing  $mono_libdir/   makes things work.

For what it's worth, the previous version had this:

 <dllmap dll="MonoPosixHelper" target="/usr/lib64/libMonoPosixHelper.so" os="!windows" />

Not at all sure why that one has /usr/lib64 on it and all the others have no absolute path attached to them.
Comment 3 Timotheus Pokorra 2016-03-01 04:10:55 EST
I have fixed this in Rawhide: http://pkgs.fedoraproject.org/cgit/rpms/mono.git/commit/?id=cc7b8dcb9f02810b0322b24e8ac63581d9be8146

Note You need to log in before you can comment on or make changes to this bug.