Bug 1313031 - Automate UI: Simulation Results view generates broken icons and FATAL error messages
Automate UI: Simulation Results view generates broken icons and FATAL error m...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.6.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Dávid Halász
Dmitry Misharov
ui:automate
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 14:01 EST by mkanoor
Modified: 2016-06-29 11:40 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:40:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Simulation Screen (129.66 KB, image/png)
2016-02-29 14:04 EST, mkanoor
no flags Details
production.log (30.40 KB, application/zip)
2016-04-19 04:50 EDT, Dmitry Misharov
no flags Details
Screenshot of the bug (101.14 KB, image/png)
2016-04-19 04:51 EDT, Dmitry Misharov
no flags Details

  None (edit)
Description mkanoor 2016-02-29 14:01:36 EST
Description of problem:
If you run an Automation/Simulation and look at the Results view on the right pane.
The icons are broken and the log shows fatal errors

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Automate -> Simulation
2. System/Process -> Request
3. Message -> create
4. Request -> InspectMe
5. Simulation Parameters Execute Methods (Enable)
6. Submit
7. Expand the results in the right hand pane

Actual results:
The icons are broken and the logs show
[----] I, [2016-02-29T12:04:21.619942 #1827:3fd04c384544]  INFO -- : Started GET "/miq_ae_tools/array.png" for ::1 at 2016-02-29 12:04:21 -0500
[----] I, [2016-02-29T12:04:21.620269 #1827:3fd04c3841ac]  INFO -- : Started GET "/miq_ae_tools/element.png" for ::1 at 2016-02-29 12:04:21 -0500
[----] F, [2016-02-29T12:04:21.702920 #1827:3fd04c384544] FATAL -- :   
[----] F, [2016-02-29T12:04:21.703040 #1827:3fd04c384544] FATAL -- : ActionController::RoutingError (No route matches [GET] "/miq_ae_tools/array.png"):
[----] F, [2016-02-29T12:04:21.703586 #1827:3fd04c384544] FATAL -- :   
[----] F, [2016-02-29T12:04:21.704138 #1827:3fd04c3841ac] FATAL -- :   
[----] F, [2016-02-29T12:04:21.704210 #1827:3fd04c384544] FATAL -- : /Users/madhukanoor/.gem/ruby/2.2.2/bundler/gems/rails-8f96b5d52c46/actionpack/lib/action_dispatch/middleware/debug_exceptions.rb:53:in `call'
[----] F, [2016-02-29T12:04:21.704254 #1827:3fd04c3841ac] FATAL -- : ActionController::RoutingError (No route matches [GET] "/miq_ae_tools/element.png"):
[----] F, [2016-02-29T12:04:21.704290 #1827:3fd04c384544] FATAL -- : /Users/madhukanoor/.gem/ruby/2.2.2/bundler/gems/rails-8f96b5d52c46/actionpack/lib/action_dispatch/middleware/show_exceptions.rb:31:in `call'
[----] F, [2016-02-29T12:04:21.704358 #1827:3fd04c3841ac] FATAL -- :   
[----] F, [2016-02-29T12:04:21.704436 #1827:3fd04c384544] FATAL -- : /Users/madhukanoor/.gem/ruby/2.2.2/bundler/gems/rails-8f96b5d52c46/railties/lib/rails/rack/logger.rb:36:in `call_app'


Expected results:
We should see all the relevant icons and not get a routing error

Additional info:
Comment 2 mkanoor 2016-02-29 14:04 EST
Created attachment 1131669 [details]
Simulation Screen
Comment 6 mkanoor 2016-03-21 08:59:46 EDT
David,
If you have VM instances in our CFME database, the inspectMe simulation method should have enough information to display.
Not sure if there are more problems in the controller. You might want to check with Harpreet on it.
Thanks,
Madhu
Comment 10 CFME Bot 2016-03-22 13:40:45 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/299992a71eb0cd3a3afaf61dbacb4d7ee75de67a

commit 299992a71eb0cd3a3afaf61dbacb4d7ee75de67a
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Mon Mar 21 14:06:40 2016 +0100
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Mon Mar 21 14:06:40 2016 +0100

    Fixed asset image paths on simulation tree views
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1313031

 app/controllers/miq_ae_tools_controller.rb | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
Comment 12 Dmitry Misharov 2016-04-19 04:50 EDT
Created attachment 1148416 [details]
production.log

Still getting routing error in production.log.
Comment 13 Dmitry Misharov 2016-04-19 04:51 EDT
Created attachment 1148418 [details]
Screenshot of the bug

Screenshot of the missing icons.
Comment 19 Dmitry Misharov 2016-05-04 04:13:44 EDT
Verified fixed in 5.6.0.5-beta2.4.20160503153816_1fb554f.
Comment 21 errata-xmlrpc 2016-06-29 11:40:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.