Bug 1313037 - do not install epel-release in RHEL systems
Summary: do not install epel-release in RHEL systems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Alfredo Deza
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-29 19:20 UTC by Alfredo Deza
Modified: 2016-08-23 19:31 UTC (History)
7 users (show)

Fixed In Version: ceph-installer-1.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:31:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Alfredo Deza 2016-02-29 19:20:04 UTC
Description of problem:
ceph-ansible is installing epel-release and other dependencies that should be met by RHCS

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Attempt to install RHCS on a RedHat System with the ceph-installer
2.
3.

Actual results: Tries to install ceph-release


Expected results: Does not install any other dependency because they are handled by RHCS directly


Additional info:

Comment 3 Alfredo Deza 2016-03-02 14:11:17 UTC
Pull request: https://github.com/ceph/ceph-ansible/pull/588

Comment 4 Harish NV Rao 2016-03-07 05:24:56 UTC
(In reply to Alfredo Deza from comment #0)
> Description of problem:
> ceph-ansible is installing epel-release and other dependencies that should
> be met by RHCS
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible: 100%
> 
> 
> Steps to Reproduce:
> 1. Attempt to install RHCS on a RedHat System with the ceph-installer
> 2.
> 3.
> 
> Actual results: Tries to install ceph-release
Is that epel-release instead of ceph-replease?
> 
> 
> Expected results: Does not install any other dependency 
What other dependencies should not be installed?

> because they are handled by RHCS directly
> 
> 
> Additional info:

Comment 5 Alfredo Deza 2016-03-07 13:39:01 UTC
(In reply to Harish NV Rao from comment #4)
> (In reply to Alfredo Deza from comment #0)
> > Description of problem:
> > ceph-ansible is installing epel-release and other dependencies that should
> > be met by RHCS
> > 
> > Version-Release number of selected component (if applicable):
> > 
> > 
> > How reproducible: 100%
> > 
> > 
> > Steps to Reproduce:
> > 1. Attempt to install RHCS on a RedHat System with the ceph-installer
> > 2.
> > 3.
> > 
> > Actual results: Tries to install ceph-release
> Is that epel-release instead of ceph-replease?

Good catch. I meant epel-release. Can't seem to edit that comment. Sorry for the confusion.

> > 
> > 
> > Expected results: Does not install any other dependency 
> What other dependencies should not be installed?
> 
> > because they are handled by RHCS directly
> > 
> > 
> > Additional info:

Comment 6 Harish NV Rao 2016-03-08 10:12:05 UTC
Thanks Alfredo!

Need one more clarification:

> Expected results: Does not install any other dependency 
What other dependencies should not be installed?

Comment 7 Alfredo Deza 2016-03-08 14:18:50 UTC
(In reply to Harish NV Rao from comment #6)
> Thanks Alfredo!
> 
> Need one more clarification:
> 
> > Expected results: Does not install any other dependency 
> What other dependencies should not be installed?

That is a bit harder to catch :( 

Basically, the deployment tool *should not* install dependencies for the storage package beforehand. EPEL is in clear violation of this.

All requirements should be "pulled in" when installing the actual package.

Comment 8 Harish NV Rao 2016-03-23 09:31:35 UTC
(In reply to Alfredo Deza from comment #7)
> (In reply to Harish NV Rao from comment #6)
> > Thanks Alfredo!
> > 
> > Need one more clarification:
> > 
> > > Expected results: Does not install any other dependency 
> > What other dependencies should not be installed?
> 
> That is a bit harder to catch :( 

we will check for epel-releases. We are not sure of how to catch other dependencies at this point of time.
> 
> Basically, the deployment tool *should not* install dependencies for the
> storage package beforehand. EPEL is in clear violation of this.
> 
> All requirements should be "pulled in" when installing the actual package.

Comment 9 Mike McCune 2016-03-28 22:11:59 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 14 Rachana Patel 2016-07-30 20:28:12 UTC
verified with 

ceph-ansible-1.0.5-31.el7scon.noarch
ceph - 10.2.2-29.el7cp.x86_64

- working as expected hence moving to verified.

Comment 16 errata-xmlrpc 2016-08-23 19:31:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755


Note You need to log in before you can comment on or make changes to this bug.