Bug 1313065 - fetching lazy files over http results in Forbidden
fetching lazy files over http results in Forbidden
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Justin Sherrill
Roman Plevka
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 15:45 EST by Justin Sherrill
Modified: 2016-07-27 05:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:03:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13961 None None None 2016-04-22 12:31 EDT
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 08:24:38 EDT

  None (edit)
Description Justin Sherrill 2016-02-29 15:45:11 EST
Description of problem:

When trying to fetch files from a kickstart tree such as:

/pulp/repos/Default_Organization/Library/custom/kickstart/http-cdn-test/images/pxeboot/vmlinuz

fails with a Forbidden error when the repo is using lazy syncing

Version-Release number of selected component (if applicable):
6.2.0 SNAP 1

How reproducible:
Always

Steps to Reproduce:
1.  Sync the 6.6 kickstart tree 
2.  In the browser try to fetch http://hostname/pulp/repos/Default_Organization/Library/content/dist/rhel/server/6/6.6/x86_64/kickstart/images/pxeboot/vmlinuz
(adjusting the hostname and org name as appropriate)

Actual results:
Forbidden

Expected results:
The file downloads (after a redirect)


Additional info:
Comment 1 Justin Sherrill 2016-02-29 15:47:22 EST
Created redmine issue http://projects.theforeman.org/issues/13961 from this bug
Comment 3 Bryan Kearney 2016-02-29 16:11:20 EST
Upstream bug component is WebUI
Comment 4 Bryan Kearney 2016-03-14 10:11:32 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/13961 has been closed
Comment 6 Roman Plevka 2016-04-01 12:03:06 EDT
VERIFIED
on sat 6.2.0 Snap #6.

accessing
http://<sat6server>/pulp/repos/Default_Organization/Library/content/dist/rhel/server/6/6.6/x86_64/kickstart/images/pxeboot/vmlinuz

after enabling&syncing the kickstart repo with download_policy: ondemand

now triggers 302 with Location header set to: 
"http://<sat6server>:80/streamer/var/lib/pulp/content/units/distribution/ac/a<hash>%3D;signature=<signature_hash>"

which finally results in 200 providing the vmlinuz file
Comment 8 errata-xmlrpc 2016-07-27 05:03:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.