Bug 1313069 - Remove ostree branches from the API and UI
Remove ostree branches from the API and UI
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: David Davis
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 15:57 EST by Partha Aji
Modified: 2016-07-27 05:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:24:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no ostree "Manage Branches" on ostree repo info page. (58.67 KB, image/png)
2016-04-29 08:32 EDT, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13955 None None None 2016-04-22 11:55 EDT

  None (edit)
Description Partha Aji 2016-02-29 15:57:48 EST
We'll be removing the feature where users will pull individual branches for Katello 3.0.
Comment 1 Partha Aji 2016-02-29 15:57:50 EST
Created from redmine issue http://projects.theforeman.org/issues/13955
Comment 2 Partha Aji 2016-02-29 15:57:53 EST
Upstream bug assigned to daviddavis@redhat.com
Comment 4 Bryan Kearney 2016-03-01 20:05:44 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13955 has been closed
-------------
David Davis
Applied in changeset commit:katello|42fc8624e96b26b9d3aff485280964db985e8055.
Comment 6 Sachin Ghai 2016-04-20 07:45:00 EDT
Hey David, Partha: Please advice what needs to be tested here for verification of this issue ? Thanks.
Comment 7 David Davis 2016-04-22 17:01:27 EDT
I wouldn't worry to much about testing this. Maybe:

1. Create an ostree repo
2. On the repository info screen and confirm that there's no Manage Branches section taht allows you to edit the branches for an ostree repo.
3. Sync the repo
4. Repeat step 2. Also, make sure you see all the ostree repo branches.
Comment 8 Partha Aji 2016-04-22 17:10:26 EDT
This commit was in way back and updates to this have already made it in. We now automatically pull all the branches related to a repo when you sync. 
I agree that steps listed verify this bz.
Comment 9 Sachin Ghai 2016-04-29 08:31:57 EDT
Verified with Satellite6 beta snap9.

I don't see any section named with "Manage Branches" under ostree repo info page. I just can see ostree branch count and can view branches. On creating the ostree repo, branch count set to 0. 

After syncing the repo, I can see ostree branches.
Comment 10 Sachin Ghai 2016-04-29 08:32 EDT
Created attachment 1152277 [details]
no ostree "Manage Branches" on ostree repo info page.
Comment 12 errata-xmlrpc 2016-07-27 05:24:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.