Bug 1313122 - Schedule worker exceeding memory threshold and being restarted.
Schedule worker exceeding memory threshold and being restarted.
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Performance (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: dmetzger
Jeff Teehan
perf:worker
: ZStream
Depends On:
Blocks: 1317914
  Show dependency treegraph
 
Reported: 2016-02-29 20:10 EST by dmetzger
Modified: 2016-06-29 11:40 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1317914 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:40:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dmetzger 2016-02-29 20:10:02 EST
Description of problem:

Because the new generational GC trades additional memory utilization for less CPU utilization, the worker is consuming more than the default configuration of 250MiB much of the time. This causes the worker to be terminated and restarted.

Version-Release number of selected component (if applicable):

5.5.2

How reproducible:

More than 50% of the time under moderate load.

Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 CFME Bot 2016-03-01 10:29:24 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=230fc0f5fa7059bf7a382bd4c153cac44acd9f36

commit 230fc0f5fa7059bf7a382bd4c153cac44acd9f36
Author:     Dennis Metzger <dmetzger@redhat.com>
AuthorDate: Mon Feb 29 20:16:46 2016 -0500
Commit:     Dennis Metzger <dmetzger@redhat.com>
CommitDate: Mon Feb 29 20:16:46 2016 -0500

    Increasing the schedule_worker memory threshold to 300Mib
    as it now exceeds the current 250MiB default more the half
    the time. The additional memory utilization is the result
    of the generation GC trading memory for CPU utilization.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1313122

 config/vmdb.tmpl.yml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 3 CFME Bot 2016-03-01 10:29:28 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=fe3d85a6f8e798ab38619066d3bc647a7bdd8e8e

commit fe3d85a6f8e798ab38619066d3bc647a7bdd8e8e
Merge: f6db2d6 230fc0f
Author:     Joe Rafaniello <jrafanie@redhat.com>
AuthorDate: Tue Mar 1 10:23:54 2016 -0500
Commit:     Joe Rafaniello <jrafanie@redhat.com>
CommitDate: Tue Mar 1 10:23:54 2016 -0500

    Merge branch '5.5.z' into '5.5.z'
    
    Increasing the schedule_worker memory threshold to 300Mib
    
    Increasing the default memory threshold to 300MiB because
    the schedule_worker routinely exceeds the current 250MiB
    as a result of the generational GC trading more memory
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1313122
    
    See merge request !827

 config/vmdb.tmpl.yml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 4 dmetzger 2016-03-01 10:47:29 EST
Merge Request #827
Comment 5 Jeff Teehan 2016-04-19 15:45:28 EDT
Verified the local appliance setting is correct per the code check-in above.  Moving to verified on 5.6.0.1 Beta 2 using 10.16.7.174
Comment 7 errata-xmlrpc 2016-06-29 11:40:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.