Bug 1313169 - Ansible installer tries to enable etcd_container service even though containerized=false
Ansible installer tries to enable etcd_container service even though containe...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Munilla
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 02:02 EST by Kenjiro Nakayama
Modified: 2016-07-03 20:44 EDT (History)
9 users (show)

See Also:
Fixed In Version: openshift-ansible-3.0.57-1.git.0.c633ce7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 12:38:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2193661 None None None 2016-03-09 00:37 EST

  None (edit)
Description Kenjiro Nakayama 2016-03-01 02:02:29 EST
Description of problem:

Ansible installer tries to enable etcd_container service even though containerized=false

Version-Release number of selected component (if applicable):

atomic-openshift-3.1.1.6-3.git.16.5327e56.el7aos.x86_64

How reproducible:
Steps to Reproduce:

1. Set OSE v3 installation ansible with containerized=false and etcd hosts.

(e.g.)
containerized=false
  ...
[OSEv3:children]
etcd
  ...
[etcd]
  ...
xxxxx.example.com
yyyyy.example.com

2. Run ansible installer
3. Hit the error below

TASK: [etcd | Enable etcd] ****************************************************
failed: [xxxx.example.com] => {"failed": true}
msg: Error when trying to enable etcd_container: rc=1 Failed to execute operation: Access denied


Actual results:

Hit following error:

TASK: [etcd | Enable etcd] ****************************************************
failed: [xxxx.example.com] => {"failed": true}
msg: Error when trying to enable etcd_container: rc=1 Failed to execute operation: Access denied

Expected results:

Install without any error

Additional info:

I will upload users log files in private.
Comment 3 Kenjiro Nakayama 2016-03-01 02:08:12 EST
If I executed "systemctl enable etcd_container" instead of "etcd", I got same error "Access denied"[1].

From this, I guess it is a bug of Ansible installer, it should run systemctl enable etcd. 

If this is a bug, could you please provide us with workaround?

[1]
# systemctl enable etcd_container
Failed to execute operation: Access denied
Comment 4 Kenjiro Nakayama 2016-03-01 07:34:40 EST
Sorry, I forgot to tell the ansible version

$ cat ansible-rpm-qa-output.txt |grep ansible
ansible-1.9.4-1.el7aos.noarch
openshift-ansible-roles-3.0.35-1.git.0.6a386dd.el7aos.noarch
openshift-ansible-3.0.35-1.git.0.6a386dd.el7aos.noarch
openshift-ansible-lookup-plugins-3.0.35-1.git.0.6a386dd.el7aos.noarch
openshift-ansible-playbooks-3.0.35-1.git.0.6a386dd.el7aos.noarch
openshift-ansible-filter-plugins-3.0.35-1.git.0.6a386dd.el7aos.noarch
Comment 5 Brenton Leanhardt 2016-03-01 11:03:41 EST
Does this happen on openshift-ansible-3.0.47-1.git.0.4498ce3.el7aos ?  That's the currently released version.
Comment 6 Kenjiro Nakayama 2016-03-01 21:38:57 EST
Yes, it does. The customer confirmed it failed with current released version.
Comment 8 Kenjiro Nakayama 2016-03-02 05:03:59 EST
OK, I think I understand this bug. 
If we set containerized=false in /etc/ansible/hosts as below, some parts of the ansible tries to install by containerized mode.

~~~
containerized=false
~~~

The doc[1] is wrong or installer's bug?

https://docs.openshift.com/enterprise/3.1/install_config/install/advanced_install.html#configuring-ansible
"If set to false or unset, the default RPM method is used."


NOTE: I know there is a workaround to unset containerized=false.
Comment 9 Brenton Leanhardt 2016-03-02 07:57:39 EST
We're discussing https://github.com/openshift/openshift-ansible/pull/1533 as a potential fix for this.
Comment 10 Kenjiro Nakayama 2016-03-02 22:40:01 EST
Although I commented on https://github.com/openshift/openshift-ansible/pull/1533, you may hit another containerized installation issue.

~~~
TASK: [openshift_master_ca | Create the master certificates if they do not already exist] ***
failed: [master.example.com] => {"cmd": "/usr/local/bin/oadm create-master-certs --hostnames=kubernetes.default,10.67.112.120,kubernetes.default.svc.cluster.local,kubernetes,openshift.default....}
msg: [Errno 2] No such file or directory
~~~

I will attach the entire log in private.
Comment 12 Kenjiro Nakayama 2016-03-02 23:48:53 EST
(In reply to Kenjiro Nakayama from comment #10)

As for the new issue, PR has been opened.

https://github.com/openshift/openshift-ansible/pull/1537
Comment 17 Ma xiaoqiang 2016-03-14 21:22:16 EDT
Check on openshift-ansible-3.0.57-1.git.0.c633ce7.el7.noarch

Install ha-master env with "containerized=false" successfully, move this issue to VERIFIED.
Comment 19 errata-xmlrpc 2016-05-12 12:38:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1065

Note You need to log in before you can comment on or make changes to this bug.