Bug 1313173 - The physical network interface is configured even when the vlan interface is defined in kickstart
The physical network interface is configured even when the vlan interface is ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Samantha N. Bueno
Release Test Team
:
Depends On: 1341636
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 02:11 EST by Abhijeet Sadawarte
Modified: 2016-11-03 19:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.76-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:22:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installtion logs (400.00 KB, application/x-tar)
2016-03-01 02:11 EST, Abhijeet Sadawarte
no flags Details
anaconda.log extracted from installation_logs.tar (7.31 KB, text/plain)
2016-05-23 20:19 EDT, Brian Lane
no flags Details
dev.log extracted from installation_logs.tar (22.15 KB, text/plain)
2016-05-23 20:19 EDT, Brian Lane
no flags Details
dmesg.log extracted from installation_logs.tar (50.53 KB, text/plain)
2016-05-23 20:19 EDT, Brian Lane
no flags Details
fdisk.log extracted from installation_logs.tar (1.14 KB, text/plain)
2016-05-23 20:20 EDT, Brian Lane
no flags Details
ifcfg.log extracted from installation_logs.tar (14.46 KB, text/plain)
2016-05-23 20:20 EDT, Brian Lane
no flags Details
mpath.log extracted from installation_logs.tar (182 bytes, text/plain)
2016-05-23 20:20 EDT, Brian Lane
no flags Details
packaging.log extracted from installation_logs.tar (96.17 KB, text/plain)
2016-05-23 20:20 EDT, Brian Lane
no flags Details
parted.log extracted from installation_logs.tar (1.59 KB, text/plain)
2016-05-23 20:20 EDT, Brian Lane
no flags Details
proc_part.log extracted from installation_logs.tar (390 bytes, text/plain)
2016-05-23 20:20 EDT, Brian Lane
no flags Details
proc_scsi.log extracted from installation_logs.tar (177 bytes, text/plain)
2016-05-23 20:20 EDT, Brian Lane
no flags Details
program.log extracted from installation_logs.tar (29.47 KB, text/plain)
2016-05-23 20:20 EDT, Brian Lane
no flags Details
storage.log extracted from installation_logs.tar (84.21 KB, text/plain)
2016-05-23 20:20 EDT, Brian Lane
no flags Details
syslog extracted from installation_logs.tar (70.58 KB, text/plain)
2016-05-23 20:20 EDT, Brian Lane
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2158 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2016-11-03 09:13:55 EDT

  None (edit)
Description Abhijeet Sadawarte 2016-03-01 02:11:54 EST
Created attachment 1131812 [details]
installtion logs

Description of problem:

During the installation of RHEL 7.2, physical network interface is configured even when the vlan interface is defined in kickstart and had to manually up the VLAN after the first boot. 

Version-Release number of selected component (if applicable):
RHEL 7.2

How reproducible:

100%, the VLAN interface will not come up

Steps to Reproduce:
1. kickstart file used in reproducer:

~~~
install
text
cdrom
lang en_US
keyboard us
#network --bootproto dhcp onboot=yes
network --device=eth0 --bootproto=dhcp --onboot=no
network --device=eth0 --vlanid=101 --bootproto=static --ip=192.168.100.100 --netmask=255.255.255.0 --gateway=192.168.100.100 --nameserver=192.168.100.100 --hostname=test --onboot=yes
zerombr
bootloader --location mbr --append=" biosdevname=0 net.ifnames=0 "
timezone America/Denver
auth --enablemd5 --enableshadow
rootpw redhat
selinux --disabled
firewall --disabled
skipx
clearpart --all --initlabel 

part /boot --fstype=ext3 --size=200 
part pv.01 --size=1000 --grow 
part swap --size=1000  --fstype=swap
volgroup myvg pv.01 
logvol / --vgname=myvg --name=rootvol --size=1000 --grow

%packages 
@base
@core
%end

%post --nochroot
dmesg &> /tmp/dmesg.log
fdisk -l &> /tmp/fdisk.log
parted -sl &> /tmp/parted.log
cat /proc/partitions &> /tmp/proc_part.log
multipath -ll &> /tmp/mpath.log
ls -lR /dev &> /tmp/dev.log
cat /proc/scsi/scsi &> /tmp/proc_scsi.log
tar cvf /mnt/sysimage/root/installation_logs.tar /tmp/*log*
%end 
~~~


2.

anaconda logs seen during installation:

~~~
12:04:01,308 DEBUG anaconda: setting locale to: en_US.UTF-8
12:04:01,322 DEBUG anaconda: network: devices found ['eth0']
12:04:01,498 DEBUG anaconda: network: pre kickstart - adding connection for eth0.101
12:04:01,507 DEBUG anaconda: network: kickstart pre section applied for devices ['eth0.101']
12:04:01,624 DEBUG anaconda: setOnboot: UnknownDeviceError('eth0.101', GLib.Error('GDBus.Error:org.freedesktop.NetworkManager.UnknownDevice: No device found for the requested iface.', 'g-io-error-quark', 36))
12:04:01,625 DEBUG anaconda: network: setting real kickstart ONBOOT value for devices ['eth0', 'eth0.101']
~~~

Actual results:

vlan interface not being activated. 

Expected results:

1. The interface eth0 had dhcp IP address during installation, as that is a primary device from where installation was carried out, the same settings will reflect on the base machine post installation.

2. the device eth0.101 should have been enabled as it was mentioned --onboot=yes, but it looked onboot=no.

3. After the installation, I did modify both the files /etc/sysconfig/network-scripts/ifcfg-eth0 and /etc/sysconfig/network-scripts/ifcfg-eth0.101.

4. The changes were as follows.

/etc/sysconfig/network-scripts/ifcfg-eth0 => onboot=no
/etc/sysconfig/network-scripts/ifcfg-eth0.101 => onboot=yes

5. Restarted the network service

        service network restart

The device eth0 got down and eth0.101 got up with proper configurations.


Additional info:

- attaching installation logs (installation_logs.tar)
- same behavior seen in RHEL 6.7 testing
Comment 3 Brian Lane 2016-05-23 20:19:52 EDT
Created attachment 1160842 [details]
anaconda.log extracted from installation_logs.tar
Comment 4 Brian Lane 2016-05-23 20:19:55 EDT
Created attachment 1160843 [details]
dev.log extracted from installation_logs.tar
Comment 5 Brian Lane 2016-05-23 20:19:57 EDT
Created attachment 1160844 [details]
dmesg.log extracted from installation_logs.tar
Comment 6 Brian Lane 2016-05-23 20:20:00 EDT
Created attachment 1160845 [details]
fdisk.log extracted from installation_logs.tar
Comment 7 Brian Lane 2016-05-23 20:20:02 EDT
Created attachment 1160846 [details]
ifcfg.log extracted from installation_logs.tar
Comment 8 Brian Lane 2016-05-23 20:20:04 EDT
Created attachment 1160847 [details]
mpath.log extracted from installation_logs.tar
Comment 9 Brian Lane 2016-05-23 20:20:07 EDT
Created attachment 1160848 [details]
packaging.log extracted from installation_logs.tar
Comment 10 Brian Lane 2016-05-23 20:20:09 EDT
Created attachment 1160849 [details]
parted.log extracted from installation_logs.tar
Comment 11 Brian Lane 2016-05-23 20:20:12 EDT
Created attachment 1160850 [details]
proc_part.log extracted from installation_logs.tar
Comment 12 Brian Lane 2016-05-23 20:20:14 EDT
Created attachment 1160851 [details]
proc_scsi.log extracted from installation_logs.tar
Comment 13 Brian Lane 2016-05-23 20:20:17 EDT
Created attachment 1160852 [details]
program.log extracted from installation_logs.tar
Comment 14 Brian Lane 2016-05-23 20:20:20 EDT
Created attachment 1160853 [details]
storage.log extracted from installation_logs.tar
Comment 15 Brian Lane 2016-05-23 20:20:23 EDT
Created attachment 1160854 [details]
syslog extracted from installation_logs.tar
Comment 16 Radek Vykydal 2016-06-03 11:01:37 EDT
With patch for bug #1341636 and some additional patches we should be able to fix the issue.

Updates image with the patches for RHEL 7.2 is available at:
https://rvykydal.fedorapeople.org/updates.vlanonboot72.img

You can check if it fixes the issue by using inst.updates boot option, eg
updates=https://rvykydal.fedorapeople.org/updates.vlanonboot72.img
or with kickstart updates command, eg
updates https://rvykydal.fedorapeople.org/updates.vlanonboot72.img
Comment 20 errata-xmlrpc 2016-11-03 19:22:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.