Bug 131320 - Guayaquil is not the capital of Ecuador
Guayaquil is not the capital of Ecuador
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: tzdata (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-30 18:01 EDT by Ernesto Pérez
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 06:48:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ernesto Pérez 2004-08-30 18:01:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
Whenever I have to install or change the timezone to match our zone,
we have to choose America/Guayaquil or America/Bogota or America/Lima

Lima is the capital of Per�, Bogot� the capital of Colombia. Guayaquil
is a big city in Ecuador however it is not the capital of Ecuador.

Even windows lets you choose Quito in the time zone (Bogot�, Lima,
Quito). Can you please fix this so When selecting the zone for Ecuador
the capital of Ecuador (Quito) is showed instead of Guayaquil?

Guayaquil can stay there in the timezones, just that I think you only
record the capital of each country.

regards
Ernesto

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run "setup"
2. Select Timezone configuration
3. Look for America/Quito (will not find it). Look for America/Bogota,
or America/anyothercapital
    

Actual Results:  You must choose anything GMT-5 but Quito, because
Quito is not in the list. But Guayaquil an important city but not the
capital of Ecuador.

Expected Results:  You should find America/Quito, the capital of
Ecuador. And not America/ Guayaquil, they are both in the same timezone

Additional info:

Galapagos island time is correct, don't touch it.
Comment 1 Jakub Jelinek 2004-08-31 06:48:57 EDT
The choice of cities for tzdata is not driven by what city is a capital
or not, but about historical timezone rules in the particular area.
For many countries capital cities are missing and there are other
cities instead.
If you want, you can argue with tzdata maintainers
(tz@elsie.nci.nih.gov), we are definitely not going to diverge
from upstream tzdata.

Note You need to log in before you can comment on or make changes to this bug.