Bug 1313207 - ca.subsystem.certreq missing from CS.cfg
ca.subsystem.certreq missing from CS.cfg
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pki-core (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ade Lee
Asha Akkiangady
Aneta Šteflová Petrová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 03:16 EST by German Parente
Modified: 2017-08-13 15:49 EDT (History)
13 users (show)

See Also:
Fixed In Version: pki-core-9.0.3-48.el6
Doc Type: Bug Fix
Doc Text:
The ca.subsystem.certreq parameter is no longer reported missing Previously, Identity Management (IdM) expected the *ca.subsystem.certreq* parameter to be defined in the `CS.cfg` public key infrastructure (PKI) configuration file. When starting the IdM server, an error occurred if *ca.subsystem.certreq* was missing. The error was not necessary because neither PKI nor IdM services use the parameter. To fix this problem, PKI code has been updated to ensure the parameter is only retrieved if it exists.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:33:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console.log (1.95 KB, text/plain)
2016-03-29 05:42 EDT, Abhijeet Kasurde
no flags Details

  None (edit)
Description German Parente 2016-03-01 03:16:23 EST
Description of problem:

at ipa startup, customer has the following error:


Restarting CA Service

Stopping pki-ca: waiting for processes 16466 to exit

killing 16466 which did not stop after 30 seconds          [WARNING]

                                                           [  OK  ]

Traceback (most recent call last):

  File "/usr/sbin/pki-server", line 89, in <module>

    cli.execute(sys.argv)

  File "/usr/sbin/pki-server", line 84, in execute

    super(PKIServerCLI, self).execute(args)

  File "/usr/lib/python2.6/site-packages/pki/cli.py", line 195, in execute

    module.execute(module_args)

  File "/usr/lib/python2.6/site-packages/pki/server/cli/upgrade.py", line 103, in execute

    scriptlet.execute()

  File "/usr/lib/python2.6/site-packages/pki/server/upgrade/__init__.py", line 50, in execute

    cert = self.subsystem.get_system_cert('subsystem')

  File "/usr/lib/python2.6/site-packages/pki/server/__init__.py", line 93, in get_system_cert

    cert['request'] = base64.b64decode(self.config['%s.%s.certreq' % (self.prefix, tag)])

KeyError: 'ca.subsystem.certreq'

Starting pki-ca:                                           [  OK  ]


Version-Release number of selected component (if applicable): pki-ca-9.0.3-45.el6_7.noarch


How reproducible: I don't know the root cause of why the value dissapear.



Steps to Reproduce: N/A


Expected results:


Additional info:

Fraser has found the workaround in freeipa alias

=========================================================
You can resolve the issue by stopping pki-cad, adding
'ca.subsystem.certreq=' (empty value) to CS.cfg, then restarting
pki-cad.  AFAICT the absense of the certreq field will not cause any
problems.

I'm still investigating what caused the 'ca.subsystem.certreq'
config to disappear from CS.cfg in the first place.
===========================================================

thanks,

German.
Comment 3 Ade Lee 2016-03-11 11:05:59 EST
Fix checked into rhel 6.8 branch ..

Counting objects: 62, done.
Compressing objects: 100% (31/31), done.
Writing objects: 100% (32/32), 5.18 KiB, done.
Total 32 (delta 18), reused 0 (delta 0)
To ssh://git.app.eng.bos.redhat.com/srv/git/pki.git
   3637b1f..dd5039f  DOGTAG_9_0_RHEL_BRANCH -> DOGTAG_9_0_RHEL_BRANCH

Matt will be creating builds.

This fix ensures that we only attempt to retrieve this parameter if it exists.
Currently, we make no use of this parameter - and if we need it later, we can retrieve it from the database.

So, if the parameter does not exist, no error should be seen.
Comment 4 Matthew Harmsen 2016-03-11 13:07:04 EST
I would suggest something like the following for doc text:

Occasionally, upon IPA server startup, an error would be encountered due to
a missing *ca.subsystem.certreq* parameter in the from PKI configuration
file 'CS.cfg'.  Currently, since neither PKI nor IPA services utilize this
parameter, code has been added to PKI to ensure that this parameter is only
retrieved if it exists.
Comment 6 Abhijeet Kasurde 2016-03-29 05:42:09 EDT
Verified using version ::

pki-*-9.0.3-49.el6.noarch
ipa-server-3.0.0-50.el6.x86_64

For verification step refer attachment.
Comment 7 Abhijeet Kasurde 2016-03-29 05:42 EDT
Created attachment 1141155 [details]
console.log
Comment 9 errata-xmlrpc 2016-05-10 20:33:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0909.html

Note You need to log in before you can comment on or make changes to this bug.