Bug 1313247 - [RFE]: gdeploy rebase to version 2.0
[RFE]: gdeploy rebase to version 2.0
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: RHGS 3.1.3
Assigned To: Nandaja Varma
Anush Shetty
: FutureFeature, ZStream
Depends On:
Blocks: 1311386
  Show dependency treegraph
 
Reported: 2016-03-01 04:03 EST by Sachidananda Urs
Modified: 2016-06-23 01:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: gdeploy-2.0-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:30:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2016-03-01 04:03:53 EST
gdeploy version 2.0 is redesigned to support ROBO and Aplo.
This release includes code changes to make backend-setup and
other features more flexible.
Comment 3 Sachidananda Urs 2016-03-17 04:48:23 EDT
What's new in 2.0?

As part of rebase gdeploy will support the following features:

   - Multiple volume support, now one can create multiple volumes in a single
     configuration file.
   - Adds support to create volume and set volume options in the same section.
   - Support to run shell scripts on remote hosts. gdeploy configuration file
     allows provision to mention the shell script which will be copied and run
     on the remote host.
   - Support for gluster features like snapshot, nfs-ganesha,  
     backend-reset, geo-replication, and SAMBA.
   - Adds configurable option to reserve space for snapshots while creating
     logical volumes.
   - Adds Subscription-manager support.
   - yum module support.
   - firewalld module support.
   - Improvement to configuration file:
     - Now the sections can be written like:
       [module:host], for e.g: [backend-setup:10.0.0.10] ...
     - Multiple invocation of modules. For eg: [shell1], [shell2] for multiple
       shell invocations.
   - Bug fixes
Comment 6 Anush Shetty 2016-04-12 05:54:28 EDT
Verifying this with gdeploy-2.0-5.el7rhgs.noarch
Comment 8 errata-xmlrpc 2016-06-23 01:30:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1249

Note You need to log in before you can comment on or make changes to this bug.