Bug 1313248 - perl-Date-Handler-1.2-5.fc25 FTBFS: Locale french does not seem to be implemented on this system
perl-Date-Handler-1.2-5.fc25 FTBFS: Locale french does not seem to be impleme...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Date-Handler (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 04:05 EST by Petr Pisar
Modified: 2016-03-26 14:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Date-Handler-1.2-6.fc25 perl-Date-Handler-1.2-6.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:08:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-03-01 04:05:31 EST
perl-Date-Handler-1.2-5.fc25 fails to build in F25 because tests fail:

t/3ranges.t .......... ok
Locale french does not seem to be implemented on this system, keeping locale en_US
# Test 1 got: "wednesday" (/home/test/fedora/perl-Date-Handler/Date-Handler-1.2/blib/lib/Date/Handler/Test.pm at line 1082)
#   Expected: "mercredi"
#  /home/test/fedora/perl-Date-Handler/Date-Handler-1.2/blib/lib/Date/Handler/Test.pm line 1082 is:     ok(lc $day_french, lc "Mercredi");
Locale spanish does not seem to be implemented on this system, keeping locale en_US
# Test 2 got: "wednesday" (/home/test/fedora/perl-Date-Handler/Date-Handler-1.2/blib/lib/Date/Handler/Test.pm at line 1088)
#   Expected: "mi\xE9rcoles"
#  /home/test/fedora/perl-Date-Handler/Date-Handler-1.2/blib/lib/Date/Handler/Test.pm line 1088 is:     ok(lc $day_spanish, lc "mi�rcoles");
t/4locale.t ..........
Failed 2/2 subtests

This is caused by removal of French and Spanish locales from glibc. Proper fix should be to build-require glibc-langpack-fr and glibc-langpack-es.

Similar issue will be in F24.
Comment 1 Fedora Update System 2016-03-14 12:48:16 EDT
perl-Date-Handler-1.2-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-04e14c398f
Comment 2 Fedora Update System 2016-03-15 17:31:26 EDT
perl-Date-Handler-1.2-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-04e14c398f
Comment 3 Fedora Update System 2016-03-26 14:08:33 EDT
perl-Date-Handler-1.2-6.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.