Bug 1313260 - liblas-config reports wrong libraries
liblas-config reports wrong libraries
Status: CLOSED DUPLICATE of bug 1300860
Product: Fedora
Classification: Fedora
Component: liblas (Show other bugs)
23
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Devrim GÜNDÜZ
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 04:30 EST by Thomas Kreuzer
Modified: 2016-03-04 03:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 03:22:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
liblas.spec bug fix (4.54 KB, text/plain)
2016-03-04 03:33 EST, Thomas Kreuzer
no flags Details

  None (edit)
Description Thomas Kreuzer 2016-03-01 04:30:59 EST
Description of problem:

liblas-config refers to the following libraries

  libboost_program_options.so
  libboost_thread.so
  libgeotiff.so
  liblaszip.so

however, those library names are not present on Fedora 23, they are:

  libboost_program_options.so.1.58.0
  libboost_thread.so.1.58.0
  libgeotiff.so.2
  liblaszip.so.6

I am not sure whether liblas-config should be patched or the corresponding libraries should create the appropriate symlinks.
There certainly are a few easy ways to patch liblas-config, but I am not sure what is considered best practice.

Version-Release number of selected component (if applicable):
liblas-1.8.0-7
Comment 1 Thomas Kreuzer 2016-03-04 03:22:57 EST

*** This bug has been marked as a duplicate of bug 1300860 ***
Comment 2 Thomas Kreuzer 2016-03-04 03:33 EST
Created attachment 1133109 [details]
liblas.spec bug fix

Note You need to log in before you can comment on or make changes to this bug.