Bug 1313274 - [RFE] Move `clients' feature out of core-modules
[RFE] Move `clients' feature out of core-modules
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: RHGS 3.1.3
Assigned To: Nandaja Varma
Neha
: FutureFeature, ZStream
Depends On:
Blocks: 1311386
  Show dependency treegraph
 
Reported: 2016-03-01 05:05 EST by Sachidananda Urs
Modified: 2016-08-14 22:09 EDT (History)
6 users (show)

See Also:
Fixed In Version: gdeploy-2.0-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:29:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2016-03-01 05:05:58 EST
Currently `clients' feature is part of core modules and runs after
backend-setup, peer, and volume. 

With new projects like Aplo, the volume can be created by other
modules like kubernets. Since core-modules are executed first,
the clients will be run before kubernetes, which causes mount to
fail. Move the client out of core-modules.
Comment 3 Neha 2016-06-09 03:13:48 EDT
volume setup:

##cat volume_create.conf 

[hosts]
10.70.42.78
10.70.43.40

[backend-setup]
devices=sdb,sdc
vgs=vg1,vg2
pools=pool1,pool2
lvs=lv1,lv2
mountpoints=/mnt/data1,/mnt/data2
brick_dirs=/mnt/data1/1,/mnt/data2/2

[volume]
action=create
volname=testvol
replica=yes
replica_count=2
force=yes

## cat client.conf 
[hosts]
10.70.42.78
10.70.43.40

[clients1]
action=mount
volname=testvol
hosts=10.70.43.139
fstype=glusterfs
client_mount_points=/mnt/testvol

[clients2]
action=mount
volname=testvol
hosts=10.70.43.17
fstype=glusterfs
client_mount_points=/mnt/testvol

Don't see any issue with these configs, moving it to verified
Comment 5 errata-xmlrpc 2016-06-23 01:29:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1250

Note You need to log in before you can comment on or make changes to this bug.