Bug 1313286 - [abrt] [faf] bind: unknown function(): /usr/bin/nsupdate killed by 6
[abrt] [faf] bind: unknown function(): /usr/bin/nsupdate killed by 6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind (Show other bugs)
6.8
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Petr Menšík
Petr Sklenar
http://faf-report.itos.redhat.com/rep...
: Reproducer
Depends On:
Blocks: 1356054 1359261
  Show dependency treegraph
 
Reported: 2016-03-01 05:26 EST by Steeve Goveas
Modified: 2017-04-03 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: bind-9.8.2-0.53.rc1.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 06:06:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steeve Goveas 2016-03-01 05:26:55 EST
This bug has been created based on an anonymous crash report requested by the package maintainer.

Report URL: http://faf-report.itos.redhat.com/reports/bthash/be56540a6dd26805c87f4a49545a6492a89b9a92/

This looks similar to bz1300636

Crash email details
abrt_version:   2.0.8
backtrace_rating: 4
cgroup:         
cmdline:        /usr/bin/nsupdate -g -d -D
crash_function: isc_assertion_failed
executable:     /usr/bin/nsupdate
hostname:       ibm-p8-alpine-0.sssdad2012r2.com
kernel:         2.6.32-621.el6.ppc64
last_occurrence: 1456825869
machineid:      
pid:            13358
pkg_arch:       ppc64
pkg_epoch:      32
pkg_fingerprint: 938A 80CA F215 41EB
pkg_name:       bind-utils
pkg_release:    0.46.rc1.el6
pkg_vendor:     Red Hat, Inc.
pkg_version:    9.8.2
pwd:            /
time:           Tue 01 Mar 2016 04:51:09 AM EST
uid:            0
username:       root
var_log_messages: Mar  1 04:51:09 ibm-p8-alpine-01-lp8 abrt[13383]: Saved core dump of pid 13358 (/usr/bin/nsupdate) to /var/spool/abrt/ccpp-2016-03-01-04:51:09-13358 (39714816 bytes)

sosreport.tar.xz: Binary file, 1400424 bytes

abrt-faf-report:
:uReport: BTHASH=be56540a6dd26805c87f4a49545a6492a89b9a92
:ABRT Server: URL=http://faf-report.itos.redhat.com/reports/bthash/be56540a6dd26805c87f4a49545a6492a89b9a92

backtrace:
:[New Thread 13358]
:[Thread debugging using libthread_db enabled]
:Core was generated by `/usr/bin/nsupdate -g -d -D '.
:Program terminated with signal 6, Aborted.
:#0  0x00000fff8f814dc0 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
:64	../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
:	in ../nptl/sysdeps/unix/sysv/linux/raise.c
:
:Thread 1 (Thread 0xfff9047d4c0 (LWP 13358)):
:#0  0x00000fff8f814dc0 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
:        r4 = <value optimized out>
:        r7 = <value optimized out>
:        arg2 = 13358
:        r5 = <value optimized out>
:        r8 = <value optimized out>
:        arg3 = 6
:        r0 = <value optimized out>
:        r3 = <value optimized out>
:        r6 = <value optimized out>
:        arg1 = 0
:        sc_err = <value optimized out>
:        sc_ret = <value optimized out>
:        pd = 0xfff9047d4c0
:        pid = 0
:        selftid = 13358
:#1  0x00000fff8f816d54 in abort () at abort.c:92
:        save_stage = 2
:        act = {__sigaction_handler = {sa_handler = 0xfffd2e1e370, sa_sigaction = 0xfffd2e1e370}, sa_mask = {__val = {17590300185864, 576, 18, 17590304821576, 1100039061552, 17591429096304, 570426434, 17590311518456, 17590294872080, 0, 17587891077127, 0, 0, 17590300184763, 2676586395008836901, 0}}, sa_flags = 0, sa_restorer = 0x1}
Comment 6 Tomáš Hozza 2016-10-17 06:59:01 EDT
The same issue has been already fixed in Fedora for some time. Please see Bug #984687
Comment 7 Tomáš Hozza 2016-10-17 07:04:46 EDT
Minimal reproducer:

nsupdate <<<'
realm EXAMPLE.COM
realm EXAMPLE.COM                             
quit             
'

Fails with:
mem.c:1099: INSIST(ctx->stats[i].gets == 0U) failed, back trace
#0 0x7fbf16c388c6 in ??
#1 0x7fbf16c38a9a in ??
#2 0x7fbf16c4ab54 in ??
#3 0x7fbf16c4ae24 in ??
#4 0x40b2fd in ??
#5 0x7fbf15aa2d1d in ??
#6 0x404759 in ??
Aborted (core dumped)

bind-utils-9.8.2-0.47.rc1.el6.x86_64
Comment 16 errata-xmlrpc 2017-03-21 06:06:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0651.html

Note You need to log in before you can comment on or make changes to this bug.