Bug 1313298 - mariadb does not start
mariadb does not start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mariadb (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jakub Dorňák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 06:04 EST by Marcin Juszkiewicz
Modified: 2016-06-22 05:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 04:38:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Juszkiewicz 2016-03-01 06:04:43 EST
Description of problem:

11:21 root@puchatek:moje-skrypty# systemctl restart mariadb
Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.

11:21 root@puchatek:moje-skrypty# systemctl status mariadb
● mariadb.service - MariaDB 10.1 database server
   Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since wto 2016-03-01 11:21:11 CET; 41min ago
  Process: 29002 ExecStopPost=/usr/libexec/mysql-wait-stop (code=exited, status=0/SUCCESS)
  Process: 28970 ExecStart=/usr/libexec/mysqld --basedir=/usr $MYSQLD_OPTS $_WSREP_NEW_CLUSTER (code=exited, status=1/FAILURE)
  Process: 28931 ExecStartPre=/usr/libexec/mysql-prepare-db-dir mariadb.service (code=exited, status=0/SUCCESS)
  Process: 28900 ExecStartPre=/usr/libexec/mysql-check-socket (code=exited, status=0/SUCCESS)
 Main PID: 28970 (code=exited, status=1/FAILURE)
   Status: "MariaDB server is down"

mar 01 11:21:07 puchatek.local systemd[1]: Starting MariaDB 10.1 database server...
mar 01 11:21:08 puchatek.local mysqld[28970]: 2016-03-01 11:21:08 140230060808384 [Note] /usr/libexec/mysqld (mysqld 10.1.11-MariaDB) startin
mar 01 11:21:11 puchatek.local systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
mar 01 11:21:11 puchatek.local systemd[1]: Failed to start MariaDB 10.1 database server.
mar 01 11:21:11 puchatek.local systemd[1]: mariadb.service: Unit entered failed state.
mar 01 11:21:11 puchatek.local systemd[1]: mariadb.service: Failed with result 'exit-code'.

Version-Release number of selected component (if applicable):

10.1.11-8.fc24

How reproducible:

always

Steps to Reproduce:
1. systemctl restart mariadb

Actual results:

does not start

Expected results:

starts

Additional info:
Comment 1 Marcin Juszkiewicz 2016-03-01 06:10:44 EST
1:10.1.11-7.fc24 has same effect
Comment 2 Marcin Juszkiewicz 2016-03-01 06:15:17 EST
Same with 10.1.11-6 and 10.1.11-5 versions. Will not check older ones today.
Comment 3 Marcin Juszkiewicz 2016-03-08 05:16:23 EST
ping?
Comment 4 Jakub Dorňák 2016-03-09 06:40:24 EST
Current version in both f24 and rawhide is mariadb-server-10.1.12-2.fc24/5.
I have successfully tried to start it.
Are you able to reproduce it with current rawhide/f24 version?
Comment 5 Marcin Juszkiewicz 2016-03-09 07:02:24 EST
12:59 root@puchatek:hrw# rpm -q mariadb
mariadb-10.1.12-2.fc25.x86_64

12:59 root@puchatek:hrw# systemctl restart mariadb
Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.

12:59 root@puchatek:hrw# systemctl status mariadb
● mariadb.service - MariaDB 10.1 database server
   Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since śro 2016-03-09 12:59:33 CET; 8s ago
  Process: 8485 ExecStopPost=/usr/libexec/mysql-wait-stop (code=exited, status=0/SUCCESS)
  Process: 8453 ExecStart=/usr/libexec/mysqld --basedir=/usr $MYSQLD_OPTS $_WSREP_NEW_CLUSTER (code=exited, status=1/FAILURE)
  Process: 8417 ExecStartPre=/usr/libexec/mysql-prepare-db-dir %n (code=exited, status=0/SUCCESS)
  Process: 8388 ExecStartPre=/usr/libexec/mysql-check-socket (code=exited, status=0/SUCCESS)
 Main PID: 8453 (code=exited, status=1/FAILURE)
   Status: "MariaDB server is down"

13:00 root@puchatek:hrw# journalctl -xe
mar 09 12:59:30 puchatek.local systemd[1]: Starting MariaDB 10.1 database server...
mar 09 12:59:30 puchatek.local mysqld[8453]: 2016-03-09 12:59:30 140080268855488 [Note] /usr/libexec/mysqld (mysqld 10.1.12-MariaDB) s
mar 09 12:59:33 puchatek.local systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
mar 09 12:59:33 puchatek.local systemd[1]: Failed to start MariaDB 10.1 database server.
mar 09 12:59:33 puchatek.local systemd[1]: mariadb.service: Unit entered failed state.
mar 09 12:59:33 puchatek.local systemd[1]: mariadb.service: Failed with result 'exit-code'.
mar 09 12:59:30 puchatek.local systemd[1]: Stopped MariaDB 10.1 database server.
-- Subject: Ukończono wyłączanie jednostki mariadb.service
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Jednostka mariadb.service ukończyła wyłączanie.
mar 09 12:59:30 puchatek.local systemd[1]: Starting MariaDB 10.1 database server...
-- Subject: Rozpoczęto uruchamianie jednostki mariadb.service
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Jednostka mariadb.service rozpoczęła uruchamianie.
mar 09 12:59:30 puchatek.local mysqld[8453]: 2016-03-09 12:59:30 140080268855488 [Note] /usr/libexec/mysqld (mysqld 10.1.12-MariaDB) starting as process 8453 ...
mar 09 12:59:33 puchatek.local systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
mar 09 12:59:33 puchatek.local systemd[1]: Failed to start MariaDB 10.1 database server.
-- Subject: Jednostka mariadb.service się nie powiodła
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Jednostka mariadb.service się nie powiodła.
-- 
-- Wynik: failed.
mar 09 12:59:33 puchatek.local audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=mariadb comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
mar 09 12:59:33 puchatek.local systemd[1]: mariadb.service: Unit entered failed state.
mar 09 12:59:33 puchatek.local systemd[1]: mariadb.service: Failed with result 'exit-code'.
mar 09 12:59:33 puchatek.local polkitd[1044]: Unregistered Authentication Agent for unix-process:8381:817387 (system bus name :1.80, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale pl_PL.UTF-8) (disconnected from bus)
mar 09 12:59:48 puchatek.local audit: NETFILTER_CFG table=filter family=2 entries=0
mar 09 12:59:48 puchatek.local audit: NETFILTER_CFG table=filter family=10 entries=0
mar 09 12:59:48 puchatek.local audit: NETFILTER_CFG table=nat family=2 entries=0
mar 09 12:59:48 puchatek.local audit: NETFILTER_CFG table=mangle family=2 entries=0
mar 09 12:59:48 puchatek.local audit: NETFILTER_CFG table=filter family=2 entries=0
mar 09 12:59:48 puchatek.local audit: NETFILTER_CFG table=filter family=10 entries=0
mar 09 12:59:48 puchatek.local audit: NETFILTER_CFG table=nat family=2 entries=0
mar 09 12:59:48 puchatek.local audit: NETFILTER_CFG table=mangle family=2 entries=0
Comment 6 Marcin Juszkiewicz 2016-03-21 04:38:03 EDT
Uninstalled mariadb*, removed /var/lib/mysql/* and installed mariadb-server back. Works.
Comment 7 Marcin Juszkiewicz 2016-04-05 08:20:29 EDT
And again, the same situation happened ;(

Will move my development outside of Fedora machine.
Comment 8 Jadi 2016-06-22 05:06:12 EDT
Same problem here. The "Unregistered Authentication Agent for unix-process" appears after I import my dump from the older mariadb into the Fedora24 version of it.
Comment 9 Jadi 2016-06-22 05:35:29 EDT
(In reply to Marcin Juszkiewicz from comment #7)
> And again, the same situation happened ;(
> 
> Will move my development outside of Fedora machine.

At the end I "resolved" my issue by installing the clean mariadb-server and then importing ONLY the databases I needed (not the whole dump). 

This is the command:

# mysql -u root -p --one-database 'sefaresh' < /tmp/mysql_jun_complete_dump.mysql

Note You need to log in before you can comment on or make changes to this bug.