Bug 1313300 - quota: reduce latency for testcase ./tests/bugs/quota/bug-1293601.t
quota: reduce latency for testcase ./tests/bugs/quota/bug-1293601.t
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Manikandan
:
Depends On:
Blocks: 1313302
  Show dependency treegraph
 
Reported: 2016-03-01 06:09 EST by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1313302 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:59:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2016-03-01 06:09:09 EST
Currently test-case './tests/bugs/quota/bug-1293601.t' runs quota enable and disable 10 times each, which take a long time.

This is not a real use-case and it is enough to test once.
Comment 1 Vijay Bellur 2016-03-01 06:11:29 EST
REVIEW: http://review.gluster.org/13556 (quota: reduce latency for testcase ./tests/bugs/quota/bug-1293601.t) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2016-03-03 05:43:53 EST
REVIEW: http://review.gluster.org/13556 (quota: reduce latency for testcase ./tests/bugs/quota/bug-1293601.t) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2016-03-04 07:11:11 EST
COMMIT: http://review.gluster.org/13556 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 0b930ea4ed5ee84f0fbbd37b158ced58a06c6660
Author: vmallika <vmallika@redhat.com>
Date:   Tue Mar 1 16:40:35 2016 +0530

    quota: reduce latency for testcase ./tests/bugs/quota/bug-1293601.t
    
    Currently test-case './tests/bugs/quota/bug-1293601.t' runs quota enable
    and disable 10 times each, which take a long time.
    
    This is not a real use-case and it is enough to test once.
    
    Change-Id: Ic282d66438f89721f3c392929047ba42b85ad155
    BUG: 1313300
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13556
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 6 Niels de Vos 2016-06-16 09:59:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.