Bug 1313308 - invalid fastbin entry (free), missing glibc patch
invalid fastbin entry (free), missing glibc patch
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glibc (Show other bugs)
7.0
Unspecified Linux
urgent Severity high
: rc
: ---
Assigned To: Carlos O'Donell
qe-baseos-tools
: Patch, ZStream
Depends On: 1305406
Blocks: 1097825
  Show dependency treegraph
 
Reported: 2016-03-01 06:23 EST by Jaroslav Reznik
Modified: 2016-09-01 10:16 EDT (History)
21 users (show)

See Also:
Fixed In Version: glibc-2.17-106.el7_2.6
Doc Type: Bug Fix
Doc Text:
Previously, certain code paths used by the C library's memory allocator "fastbins" feature, which were enabled by default, were not thread-safe. When the non-safe code paths executed, the code paths could cause corruption in the allocator, which cause the application terminate unexpectedly with a segmentation fault. The thread-unsafe code paths have been made thread-safe, and the described problem no longer occurs.
Story Points: ---
Clone Of: 1305406
Environment:
Last Closed: 2016-05-12 05:59:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 15073 None None None 2016-03-01 06:23 EST
Red Hat Knowledge Base (Solution) 2173041 None None None 2016-03-01 06:23 EST

  None (edit)
Description Jaroslav Reznik 2016-03-01 06:23:23 EST
This bug has been copied from bug #1305406 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 8 Michael Petlan 2016-04-22 12:39:59 EDT
Presence of the patch checked in glibc-2.17-106.el7_2.106 build tree.
Comment 9 Michael Petlan 2016-04-22 13:42:59 EDT
Since there is no reliable reproducer, we have to be content with SanityOnly here.
Comment 11 errata-xmlrpc 2016-05-12 05:59:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1030.html

Note You need to log in before you can comment on or make changes to this bug.