Bug 1313316 - EAP7 - unable to update configuration of Distributed Cache
EAP7 - unable to update configuration of Distributed Cache
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 7 (Show other bugs)
JON 3.3.5
Unspecified Unspecified
high Severity high
: DR01
: One-off release
Assigned To: Thomas Segismont
Filip Brychta
: Triaged
Depends On:
Blocks: 1314853
  Show dependency treegraph
 
Reported: 2016-03-01 06:34 EST by Filip Brychta
Modified: 2016-06-06 14:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-06 14:57:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Brychta 2016-03-01 06:34:10 EST
Description of problem:
Update of Distributed Cache fails with {WFLYCTL0062: Composite operation failed and was rolled back. Steps that failed:={Operation step-13=WFLYCTL0201: Unknown attribute 'virtual-nodes'}}, rolled-back=true

Version-Release number of selected component (if applicable):
JON3.3.5 with eap plugin pack03-dr01

How reproducible:
Always

Steps to Reproduce:
1. create new Distributed Cache (infinispan->cache container->Create new child->Distributed Cache)
2. try update configuration of Distributed Cache


Actual results:
fails with {WFLYCTL0062: Composite operation failed and was rolled back. Steps that failed:={Operation step-13=WFLYCTL0201: Unknown attribute 'virtual-nodes'}}, rolled-back=true

Expected results:
Configuration is correctly updated

Additional info:
It's caused by different attributes in eap6 and eap7.

EAP6:
/subsystem=infinispan/cache-container=testik/distributed-cache=testdist:read-resource
{
    "outcome" => "success",
    "result" => {
        "async-marshalling" => undefined,
        "batching" => false,
        "indexing" => "NONE",
        "indexing-properties" => undefined,
        "jndi-name" => undefined,
        "l1-lifespan" => 600000,
        "mode" => "SYNC",
        "module" => undefined,
        "owners" => 2,
        "queue-flush-interval" => 10L,
        "queue-size" => 0,
        "remote-timeout" => 17500L,
        "segments" => 80,
        "start" => "LAZY",
        "statistics-enabled" => undefined,
        "virtual-nodes" => 1,
        "binary-keyed-jdbc-store" => undefined,
        "eviction" => undefined,
        "expiration" => undefined,
        "file-store" => undefined,
        "locking" => undefined,
        "mixed-keyed-jdbc-store" => undefined,
        "remote-store" => undefined,
        "state-transfer" => undefined,
        "store" => undefined,
        "string-keyed-jdbc-store" => undefined,
        "transaction" => undefined
    }
}


EAP7:
/subsystem=infinispan/cache-container=test/distributed-cache=testdist:read-resource
{
    "outcome" => "success",
    "result" => {
        "async-marshalling" => false,
        "batching" => false,
        "capacity-factor" => 1.0,
        "consistent-hash-strategy" => "INTRA_CACHE",
        "indexing" => "NONE",
        "indexing-properties" => undefined,
        "jndi-name" => undefined,
        "l1-lifespan" => 600000L,
        "mode" => "SYNC",
        "module" => undefined,
        "owners" => 2,
        "queue-flush-interval" => 10L,
        "queue-size" => 0,
        "remote-timeout" => 17500L,
        "segments" => 80,
        "start" => "LAZY",
        "statistics-enabled" => false,
        "backup-for" => {"BACKUP_FOR" => undefined},
        "component" => {
            "expiration" => undefined,
            "state-transfer" => undefined,
            "eviction" => undefined,
            "locking" => undefined,
            "backups" => undefined,
            "transaction" => undefined,
            "backup-for" => undefined,
            "partition-handling" => undefined
        },
        "eviction" => {"EVICTION" => undefined},
        "expiration" => {"EXPIRATION" => undefined},
        "locking" => {"LOCKING" => undefined},
        "state-transfer" => {"STATE_TRANSFER" => undefined},
        "store" => {"none" => undefined},
        "transaction" => {"TRANSACTION" => undefined}
    }
}

It will be necessary to check differences in other resource types as well.
Comment 1 Thomas Segismont 2016-03-11 04:45:07 EST
Pull request sent https://github.com/rhq-project/rhq/pull/214

Updated all Infinispan subsystem resource types, many attributes have
been drepecated, and while the management interface lets us write
values, the server fails to restart because the attributes are no longer
defined in the subsystem schema file.

Little bonus: added common metrics to cache resource types.

Note You need to log in before you can comment on or make changes to this bug.