Bug 1313350 - Edit user form does not save changed password(issue in related PUT method)
Edit user form does not save changed password(issue in related PUT method)
Status: VERIFIED
Product: Red Hat Storage Console
Classification: Red Hat
Component: core (Show other bugs)
2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2
Assigned To: sankarshan
sds-qe-bugs
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 07:41 EST by Martin Kudlej
Modified: 2016-07-01 07:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhscon-ceph-0.0.23-1.el7scon.x86_64, rhscon-core-0.0.24-1.el7scon.x86_64, rhscon-ui-0.0.39-1.el7scon.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2016-03-01 07:41:49 EST
Description of problem:
I've tried to save changed password from Edit user form and it has not changed password.
I've tried it also by PUT method directly and it has not worked.

Version-Release number of selected component (if applicable):
rhscon-ceph-0.0.6-8.el7.x86_64
rhscon-core-0.0.8-7.el7.x86_64
rhscon-ui-0.0.16-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. open Edit user form
2. change password
3. save
4. try to login with new password(now old password is valid)

Actual results:
Edit user form does not change password.

Expected results:
Edit user form will change password.
Comment 3 Martin Kudlej 2016-07-01 07:48:09 EDT
Tested with rhscon-ui-0.0.43-1.el7scon.noarch and it works. -> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.