This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1313365 - upgrade oracle from 5.3 to satellite 5.7 failed
upgrade oracle from 5.3 to satellite 5.7 failed
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
570
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Kašpárek
Pavel Studeník
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 08:20 EST by Pavel Studeník
Modified: 2016-04-28 07:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhn-upgrade-5.7.0.29-1-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-28 07:16:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Studeník 2016-03-01 08:20:56 EST
Description of problem:
I tried to upgrade satellite 5.3 to satellite 5.7 with external oracle and I received following error during upgrade.

>> spacewalk-schema-upgrade 
Schema upgrade: [satellite-schema-5.3.0.23-1.el5sat] -> [satellite-schema-5.7.0.11-1.el6sat]
Searching for upgrade path: [satellite-schema-5.3.0.23-1] -> [satellite-schema-5.7.0.11-1]
Searching for upgrade path: [satellite-schema-5.3.0.23] -> [satellite-schema-5.7.0.11]
Searching for upgrade path: [satellite-schema-5.3.0] -> [satellite-schema-5.7.0]
Searching for upgrade path: [satellite-schema-5.3] -> [satellite-schema-5.7]
The path: [satellite-schema-5.3] -> [satellite-schema-5.4] -> [satellite-schema-5.5] -> [satellite-schema-5.6] -> [satellite-schema-5.7]
Planning to run spacewalk-sql with [/var/log/spacewalk/schema-upgrade/20160301-074824-script.sql]

Plase make sure you have a valid backup of your database before continuing.

Hit Enter to continue or Ctrl+C to interrupt: 
Executing spacewalk-sql, the log is in [/var/log/spacewalk/schema-upgrade/20160301-074824-to-satellite-schema-5.7.log].
Upgrade failed, please see log [/var/log/spacewalk/schema-upgrade/20160301-074824-to-satellite-schema-5.7.log].
[root@test08-64 ~]# tail /var/log/spacewalk/schema-upgrade/20160301-074824-to-satellite-schema-5.7.log


Version-Release number of selected component (if applicable):
rhn-upgrade-5.7.0.27-1.el6sat.noarch

How reproducible:
always on oracle

Steps to Reproduce:
1. Install satellite 5.3 with oracle
2. try to migrate to new system with oracle
3. spacewalk-schema-upgrade

Actual results:

'SATELLITE-SCHEMA-5.5-TO-SATELLITE-SCHEMA-5.6/037-SUPPORT-FOR-ARMV5-CHANNEL.SQL.ORACL
-------------------------------------------------------------------------------------
satellite-schema-5.5-to-satellite-schema-5.6/037-support-for-armv5-channel.sql.oracle

insert into rhnChannelArch (id, label, name, arch_type_id) values
*
ERROR at line 1:
ORA-00001: unique constraint (RHNSAT.RHN_CARCH_LABEL_UQ) violated
Comment 3 Pavel Studeník 2016-04-19 07:43:59 EDT
Verified

Schema upgrade: [satellite-schema-5.3.0.23-1.el5sat] -> [satellite-schema-5.7.0.23-1.el6sat]
Searching for upgrade path: [satellite-schema-5.3.0.23-1] -> [satellite-schema-5.7.0.23-1]
Searching for upgrade path: [satellite-schema-5.3.0.23] -> [satellite-schema-5.7.0.23]
Searching for upgrade path: [satellite-schema-5.3.0] -> [satellite-schema-5.7.0]
Searching for upgrade path: [satellite-schema-5.3] -> [satellite-schema-5.7]
The path: [satellite-schema-5.3] -> [satellite-schema-5.4] -> [satellite-schema-5.5] -> [satellite-schema-5.6] -> [satellite-schema-5.7]
Planning to run spacewalk-sql with [/var/log/spacewalk/schema-upgrade/20160419-133646-script.sql]

Plase make sure you have a valid backup of your database before continuing.

Hit Enter to continue or Ctrl+C to interrupt: 
Executing spacewalk-sql, the log is in [/var/log/spacewalk/schema-upgrade/20160419-133646-to-satellite-schema-5.7.log].
The database schema was upgraded to version [satellite-schema-5.7.0.23-1.el6sat].
Comment 5 errata-xmlrpc 2016-04-28 07:16:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0698.html

Note You need to log in before you can comment on or make changes to this bug.