Bug 1313398 - Content host deletes taking abnormally long time
Content host deletes taking abnormally long time
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin (Show other bugs)
6.1.7
x86_64 Linux
high Severity high (vote)
: 6.1.8
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On: 1313544
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 09:30 EST by Chris Roberts
Modified: 2017-02-23 14:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-22 11:44:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EL7 Hotfix packages (2.43 MB, application/x-tar)
2016-03-18 17:14 EDT, Mike McCune
no flags Details
EL6 Hotfix packages (1.50 MB, application/x-tar)
2016-03-18 17:15 EDT, Mike McCune
no flags Details

  None (edit)
Comment 6 Corey Welton 2016-03-18 14:25:11 EDT
Verified on a 6.1.7 box upgraded to 6.1.8 compose 1.  removal of content hosts went from 5-10 seconds or longer to about ~1sec, using visual observation.


Marking bug verified.
Comment 7 Mike McCune 2016-03-18 17:14:05 EDT
Hotfix RPMs available for installation to resolve this issue, attached to this ticket.

Installation instructions:

1) Download either EL6 or EL7 version of the tar.gz needed for your Satellite
2) shutdown services:

# katello-service stop

3) Unpack the archive (EL7 example):

tar xvzf candlepin-0.9.49.12-EL7.tar.gz

4) Upgrade:

rpm -Uvh candlepin-*0.9.49.12-1*.rpm

5) Start services

# katello-service start

Resume operations.
Comment 8 Mike McCune 2016-03-18 17:14 EDT
Created attachment 1137884 [details]
EL7 Hotfix packages
Comment 9 Mike McCune 2016-03-18 17:15 EDT
Created attachment 1137885 [details]
EL6 Hotfix packages
Comment 11 errata-xmlrpc 2016-03-22 11:44:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0475

Note You need to log in before you can comment on or make changes to this bug.