Bug 1313421 - locale sv_SV - why? (Refresh the list of lang-exceptions)
locale sv_SV - why? (Refresh the list of lang-exceptions)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On: 1349145
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 10:18 EST by Mattias Ellert
Modified: 2017-01-02 05:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-02 05:56:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2016-03-01 10:18:53 EST
Description of problem:

The filesystem package installs

/usr/share/locale/sv_SV
/usr/share/man/sv_SV

This would mean Swedish as spoken in El Salvador, which really does not make sense. So why is it there?

sv_SE (Swedish in Sweden) is there.
sv_FI (Swedish in Finland) is missing though.

Version-Release number of selected component (if applicable):

filesystem-3.2-35.fc23.x86_64
filesystem-3.2-37.fc24.x86_64
Comment 1 Ondrej Vasik 2016-06-22 07:50:03 EDT
Sorry for late reply.

I believe this was caused by https://git.fedorahosted.org/cgit/filesystem.git/commit/lang-exceptions?id=8f4ce52a562812b9541604b2b862442282197af0 - lang-exceptions file is part of filesystem package build - and can be refreshed by running something like $(repoquery -qal | awk -F '/' '/^\/usr\/share\/locale\/[a-z]*[_@]+/ { print $5 }' | sort -u) . Other than that - filesystem lists all languages listed in iso 639 and iso 3166 (provided by iso-codes package).

sv_FI is not used by any Fedora package (based on the repoquery command provided above) - it used to be in Fedora 8 - used by beryl-manager. 
sv_SV seems to be used by some projects ( https://github.com/JLahti/bacula-web/tree/master/locale/sv_SV/LC_MESSAGES ) probably based on "Sverige" . In current Fedora, it still seems to be used by mate-applet-lockkeys package.

As it is still in use - and I do refreshes from time to time. I consider this to be not a bug. If you don't like this directory on your system, you can file a bug against mate-applet-lockkeys, and this directory will disappear in next lang-exceptions refresh.

Meanwhile I'll keep it opened until next refresh of lang-exceptions from rawhide repos.
Comment 2 Jan Kurik 2016-07-26 00:52:57 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Note You need to log in before you can comment on or make changes to this bug.