Bug 131344 - Large file transfer to laptop slows then hangs system
Large file transfer to laptop slows then hangs system
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: gftp (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-31 05:55 EDT by Dan Rivers
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 13:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Rivers 2004-08-31 05:55:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
Fedora Core 2 2.6.8-1.521 on i686 IBM T30 Laptop

When using gftp and transfering large files off my internal FTP server
 (1GB image file) the laptop harddrive will start to thrash and the
system becomes unusable, it slows to a near stop... There is lots of
lots of HD activity but extreemly slow responce from any applications.
 This makes the OS unusable and I am unable to shut down the system
clean, only solutio is to power off.

Version-Release number of selected component (if applicable):
gftp-2.0.17-2

How reproducible:
Always

Steps to Reproduce:
1.start gftp from terminal
2.connect to local ftp server over local wifi (default orinoco drivers)
3.start transfer of 1Gb file
4. Try to use system...
    

Actual Results:  System became unusable, mass amonts of HD thrashing
and had to power off

Expected Results:  would expect performande reduction but still
usability of OS

Additional info:
Comment 1 Dan Rivers 2004-10-30 10:26:56 EDT
I have also tried this with command line ftp and connection to a
windows smb share.  Every large file causes the same issue, this is
not specific to gftp.  The transfer is going through an onboard prism
wifi card, (Prism 2.5 Wavelan Chipset).

I have recently done a new build on the system and still get this issue.

I will try through a wired nic on the same computer and report the
results.
Comment 2 Dan Rivers 2004-10-31 03:50:24 EST
OK tried this with the Lan Port instead of the wireless card, no issue
found at all.  So this seem to be only related when transfedrring
files via the wifi card.
Comment 3 Warren Togami 2004-10-31 03:53:27 EST
What kernel driver does that Prism 2.5 use?
Comment 4 Dan Rivers 2004-11-01 04:20:49 EST
This is the drivers that is shipped with Fedora Core 2, please let me 
know if you want additional info, apologies but i have only been 
using linux a short time.  Let me know if you need any info or if you 
would like me to run any commands.
Comment 5 Matthew Miller 2005-04-26 12:18:33 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 6 John Thacker 2006-10-28 13:34:01 EDT
Closing per lack of response.  Note that FC1 and FC2 are no longer
supported even by Fedora Legacy.  Please install a still supported
version and retest.  If this still occurs on FC3 or FC4 and is a
security issue, please assign to that version and Fedora Legacy.  If it still
occurs on FC5 or FC6, please reopen and assign to the correct version.

Note You need to log in before you can comment on or make changes to this bug.