Bug 131348 - haldaemon not starting
haldaemon not starting
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-31 07:45 EDT by Tomo Vuckovic
Modified: 2013-03-05 22:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 12:26:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomo Vuckovic 2004-08-31 07:45:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040831

Description of problem:
haldaemon hangs on ibm server 235

Version-Release number of selected component (if applicable):
hal-0.2.97.cvs20040823-1

How reproducible:
Always

Steps to Reproduce:
1.install fc3 development
2. haldaemon not freeze on boot

    

Additional info:
Comment 1 David Zeuthen 2004-08-31 07:54:59 EDT
Please upgrade to the latest version from Rawhide and see if that
fixes the problems. The latest version is hal-devel-0.2.97.cvs20040827-3.

If that fails please ensure all hald processes are killed and attach
the output of 'hald --daemon=no --verbose=yes' running as root. I need
the debug up until the line 'Device probing completed'. Should this
crash, please attach stack trace; see 

 http://fedora.linux.duke.edu/wiki/StackTraces

on how to generate good stack traces.

Thanks!
David
Comment 2 David Zeuthen 2004-09-27 14:14:33 EDT
Is this still an issue or may I close this bug?
Comment 3 Orion Poplawski 2004-10-01 17:51:34 EDT
I'm seeing the same thing on different hardware.  Install is fc3test2
with hal updated to hal-0.2.98.cvs20040929-1.

Last couple lines of hald --daemon=no --verbose=yes:

[I] callout.c:332: Invoking /etc/hal/devices.d/printer_remove.hal
[I] hald.c:80: Added device to GDL;
udi=/org/freedesktop/Hal/devices/scsi_host_2
[I] linux/osspec.c:758: handling /sys/devices/pci0000:00/0000:00:04.3 pci

and there the machine hangs.

# lspci -vvv -s 4.3
00:04.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin ? routed to IRQ 9

Comment 4 David Zeuthen 2004-10-18 21:48:12 EDT
I think this got fixed just a week ago as that particular sysfs
directory probably contains files that are not readable and I got a
patch to check for that. Please try the latest hal from Rawhide. 

Thanks,
David
Comment 5 David Zeuthen 2004-12-09 12:26:02 EST
Closing this bug since there was no reply. Feel free to reopen if
hal-0.4.2-1.FC3 doesn't work for you (available from fc3 updates).
Comment 6 Piotr Blaszczyk 2004-12-13 14:04:34 EST
I upgraded three i386 boxes from FC2 to FC3 and starting haldaemon on
any of them is impossible.
# /usr/sbin/hald --daemon=no --verbose=yes
19:56:50.061 [I] hald.c:394: hal 0.4.2
19:56:50.069 [I] hald.c:398: Will not daemonize
19:56:50.092 [E] hald_dbus.c:1934: dbus_bus_get(): Failed to connect
to socket /var/run/dbus/system_bus_socket: No such file or directory
Comment 7 David Zeuthen 2004-12-13 14:33:24 EST
You need to 'service messagebus start'
Comment 8 Piotr Blaszczyk 2004-12-13 17:15:22 EST
Thank you, David. I might have stopped the service myself in the
services after installation... now hald starts and my camera
beautifully plugs in very hot.

Note You need to log in before you can comment on or make changes to this bug.