Bug 1313483 - Docker repository creation: update URL help text
Docker repository creation: update URL help text
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Zach Huntington-Meath
Brad Buckingham
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 11:46 EST by Brad Buckingham
Modified: 2016-07-27 05:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:03:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13992 None None None 2016-04-22 11:48 EDT

  None (edit)
Description Brad Buckingham 2016-03-01 11:46:19 EST
Description of problem:

When creating a docker repository, the UI will provide the user with an example for the 'URL' to dockerhub.  Unfortunately, the URL previously used is no longer valid; therefore, we need to update it to a URL that currently works.

Version-Release number of selected component (if applicable):
Satellite 6.2 early snap

How reproducible:
Always

Steps to Reproduce:
1. go to Content -> Products
2. create a product via 'New Product'
3. click 'Create Repository'
4. select Type 'docker'

Actual results:

Observe text under URL indicating:
URL of the registry you want to sync. Example: https://registry.hub.docker.com

Expected results:

Change the URL to be:

https://registry-1.docker.io

Additional info:

It is quite possible that the URL for accessing dockerhub content will change again; however, this update will put it to current working URL and is based upon feedback from the pulp team.
Comment 2 Zach Huntington-Meath 2016-03-01 14:30:45 EST
Created redmine issue http://projects.theforeman.org/issues/13992 from this bug
Comment 3 Bryan Kearney 2016-03-01 18:02:06 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13992 has been closed
-------------
Zach Huntington-Meath
Applied in changeset commit:katello|e898a835b35dae8585b6843b0302532ac5eabe8b.
Comment 4 Brad Buckingham 2016-03-24 14:52:49 EDT
Verified that the help text for URL when creating a docker repository now states the following:

"URL of the registry you want to sync. Example: https://registry-1.docker.io/"

If this URL is used and a valid upstream docker name is used, content can be synced form dockerhub.
Comment 7 errata-xmlrpc 2016-07-27 05:03:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.