Bug 1313495 - migrate files based on file size
migrate files based on file size
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 12:23 EST by Dan Lambright
Modified: 2016-06-16 09:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:59:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Lambright 2016-03-01 12:23:24 EST
Description of problem:

Currently all files are migrated in tiering. Add the ability to set the size of files to migrate. This is an important performance knob.
Comment 1 Vijay Bellur 2016-03-01 15:08:02 EST
REVIEW: http://review.gluster.org/13570 (cluster/tier: add tunable to migrate files based on size) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 2 Vijay Bellur 2016-03-02 17:25:53 EST
REVIEW: http://review.gluster.org/13570 (cluster/tier: add tunable to migrate files based on size) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 3 Vijay Bellur 2016-03-10 10:13:04 EST
REVIEW: http://review.gluster.org/13570 (cluster/tier: add tunable to migrate files based on size) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 4 Vijay Bellur 2016-03-10 10:14:00 EST
REVIEW: http://review.gluster.org/13570 (cluster/tier: add tunable to migrate files based on size) posted (#4) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 5 Vijay Bellur 2016-03-11 09:41:38 EST
REVIEW: http://review.gluster.org/13570 (cluster/tier: add tunable to migrate files based on size) posted (#5) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 6 Vijay Bellur 2016-03-15 02:03:46 EDT
REVIEW: http://review.gluster.org/13570 (cluster/tier: add tunable to migrate files based on size) posted (#6) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 7 Vijay Bellur 2016-03-16 03:23:47 EDT
REVIEW: http://review.gluster.org/13570 (cluster/tier: add tunable to migrate files based on size) posted (#7) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 8 Vijay Bellur 2016-03-17 02:12:11 EDT
COMMIT: http://review.gluster.org/13570 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit adbce4e9b7dadc226d3de326d98007ed10913919
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Tue Mar 1 15:03:54 2016 -0500

    cluster/tier: add tunable to migrate files based on size
    
    This fix adds a paramater "tier-max_promote_size" to control wether
    a file is migrated or not based on its size. By default the value
    is 0, meaning all files are migrated. If set to a non-zero
    value, files larger than the parameter won't be moved
    in tiered volumes.
    
    Change-Id: Ia6b88e9b2508935bef500d956f9192e59670fe00
    BUG: 1313495
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/13570
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
Comment 9 Niels de Vos 2016-06-16 09:59:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.