Bug 1313505 - gutterball config file gets changed
gutterball config file gets changed
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin (Show other bugs)
6.1.7
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Chris Roberts
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 12:38 EST by Chris Roberts
Modified: 2016-06-21 16:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-21 16:55:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Roberts 2016-03-01 12:38:39 EST
Description of problem:
Candlepin/gutterball randomly generates a rpm.conf.save which causes an issues with satellite/katello 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install satellite 6.1.7 or upgrade a install of satellite 6.1
2. Hope it shows it self

Actual results:
when doing a fresh install of satellite/update of pkgs that the .conf files for candlepin/gutterball are kept and not overwritten, which creates an issue with the keystore and tomcat.

Expected results:
for there never to be a .conf.rpm.save file in /etc/gutterball and /etc/candlepin

Additional info:

https://blog.lnx.cx/2014/11/13/inspecting-spec-files/
https://github.com/candlepin/candlepin/blob/master/gutterball/gutterball.spec.tmpl
Comment 3 Chris Roberts 2016-05-04 14:15:21 EDT
Moving to ON_QA since gutterball is being removed in 6.2 downstream

Note You need to log in before you can comment on or make changes to this bug.