Bug 1313531 - download-policy option specifies that html tags should surround option
download-policy option specifies that html tags should surround option
Status: CLOSED DUPLICATE of bug 1325525
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
jcallaha
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 14:55 EST by jcallaha
Modified: 2016-04-12 13:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-12 13:09:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jcallaha 2016-03-01 14:55:32 EST
Description of problem:
hammer repository update's option flag download-policy tell the user that they need to pass the argument with html code tags. 

Version-Release number of selected component (if applicable):
6.2 Compose 1

How reproducible:
Always

Steps to Reproduce:
1. Create or enable a repository
2. Attempt to update the repo's download-policy (hammer repository update --id 1 --download-policy on_demand)
3. View results

Actual results:
Could not update the repository:
  Error: option '--download-policy': value must be one of '<code>immediate</code>', '<code>on_demand</code>', '<code>background</code>'

Expected results:
hammer accepts the arguments without the html tags
Comment 2 Roman Plevka 2016-03-02 04:38:09 EST
this seems to be an issue across all hammer commands, the help descriptions seem to use pre-formatted text.

other examples:
`hammer os create --help`:
...
--os-parameters-attributes OS_PARAMETERS_ATTRIBUTES   OS&#39; parameters (array or indexed hash)
...

`hammer user create --help`
...
--locale LOCALE                                   User&#39;s preferred locale
                                                   Possible value(s): '<code>ko</code>', '<code>zh_CN</code>', '<code>ca</code>', '<code>pt_BR</code>', '<code>ru</code>', '<code>sv_SE</code>', '<code>gl</code>', '<code>de</code>', '<code>zh_TW</code>', '<code>it</code>', '<code>ja</code>', '<code>en_GB</code>', '<code>es</code>', '<code>en</code>', '<code>fr</code>'
...
 --timezone TIMEZONE                               User&#39;s timezone
                                                   Possible value(s): '<code>UTC</code>', '<code>International Date Line West</code>', '<code>Midway Island</code>', '<code>American Samoa</code>', '<code>Hawaii</code>', '<code>Alaska</code>', '<code>Pacific Time (US & Canada)</code>', '<code>Tijuana</code>', '<code>Mountain Time (US & Canada)</code>', '<code>Arizona</code>', ... '<code>Samoa</code>'
 -h, --help                                        print help
Comment 3 Bryan Kearney 2016-04-12 13:09:36 EDT

*** This bug has been marked as a duplicate of bug 1325525 ***

Note You need to log in before you can comment on or make changes to this bug.