Bug 1313545 - hg-git broken since update to python2-dulwich-0.12.0-1
hg-git broken since update to python2-dulwich-0.12.0-1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hg-git (Show other bugs)
23
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: pstodulk
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 15:43 EST by Sjoerd Mullender
Modified: 2016-07-12 11:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: hg-git-0.8.5-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-12 11:07:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that fixes the problem (665 bytes, patch)
2016-03-01 15:43 EST, Sjoerd Mullender
no flags Details | Diff

  None (edit)
Description Sjoerd Mullender 2016-03-01 15:43:13 EST
Created attachment 1132035 [details]
patch that fixes the problem

Description of problem:
hg can no longer communicate with a remote git repository since python2-dulwich was updated to 0.12.0.  The problem is the incompatible way in which dulwich calls the run_command method in hggit/_ssh.py.

In the old version, the command parameter was a list of strings, in the new version, the command parameter is a string.  This means that the conversion from list to string (' '.join(command)) now gives an incorrect result.

Version-Release number of selected component (if applicable):
hg-git-0.8.2-1.fc23.noarch
python2-dulwich-0.12.0-1.fc23.x86_64

How reproducible:
100%

Steps to Reproduce:
1.hg clone git+ssh://git@github.com:some/repo.git
2.
3.

Actual results:
destination directory: repo
Invalid command: 'g i t - u p l o a d - p a c k   ' s o m e / r e p o . g i t ''
  You appear to be using ssh to clone a git:// URL.
  Make sure your core.gitProxy config option and the
  GIT_PROXY_COMMAND environment variable are NOT set.
abort: git remote error: The remote server unexpectedly closed the connection.


Expected results:
destination directory: repo
importing git objects into hg
updating to branch default
25 files updated, 0 files merged, 0 files removed, 0 files unresolved


Additional info:
The above was slightly edited to protect the innocent, you need to refer to a git repo where you have ssh access and use the correct URL.
Comment 1 Fedora Admin XMLRPC Client 2016-03-26 11:26:06 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 pstodulk 2016-06-30 20:49:10 EDT
I tested in rawhide, where it is still broken, just different fail:

$ hg clone ssh://pstodulk@pkgs.fedoraproject.org/rpms/unzip
remote: FATAL: unknown git/gitolite command: 'hg -R rpms/unzip serve --stdio'
abort: no suitable response from remote hg!

Same situation even for new upstream version. I will look at it when I have time. Help is welcomed.
Comment 3 pstodulk 2016-06-30 21:29:13 EDT
My apologize. I forgot set extensions in config file. Problem is solved in new upstream version. It will be fixed by rebase for F24 too due to more changes in other packages.
Comment 4 Fedora Update System 2016-06-30 21:54:41 EDT
hg-git-0.8.5-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-da7433152c
Comment 5 Fedora Update System 2016-07-02 16:30:23 EDT
hg-git-0.8.5-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-da7433152c
Comment 6 Fedora Update System 2016-07-12 11:07:07 EDT
hg-git-0.8.5-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.